php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30688 imap_mail's rpath don't work
Submitted: 2004-11-04 18:13 UTC Modified: 2013-02-18 00:09 UTC
Votes:18
Avg. Score:3.9 ± 1.2
Reproduced:12 of 14 (85.7%)
Same Version:4 (33.3%)
Same OS:5 (41.7%)
From: sirber at gmail dot com Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 4.3.9 OS: Gentoo Linux 2.6.9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sirber at gmail dot com
New email:
PHP Version: OS:

 

 [2004-11-04 18:13 UTC] sirber at gmail dot com
Description:
------------
Using imap_mail, and using the rpath setting, the mail I set is not used.

Thanks

St?phane B?rub?

SW:

PHP 4.3.9
* Runs on "apache" user
Exim 4.42
* /usr/sbin/exim -bd -q15m
* Runs on "mail" user
* Special config:
trusted_users = apache

Reproduce code:
---------------
$to = "xxx@yyy.com";
$sujet = "test";
$mime = "[headers and mime encoded message]";
$cc = "";
$cci = "";
$from = "zzz@aaa.com";

function imap_send ($to, $sujet, $mime, $cc, $cci, $from)
	{
		imap_mail ($to, $sujet, "", $mime, $cc, $cci, $from);
	}

Expected result:
----------------
Return-path: <zzz@aaa.com>

Actual result:
--------------
Return-path: <apache@webernic.com>

Patches

patch2 (last revision 2011-08-22 13:18 UTC by ava3ar at gmail dot com)
Patch-by-Keloran-ava3ar-at-gmail-com (last revision 2011-08-04 16:18 UTC by pajoye@php.net)

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-27 18:03 UTC] info at todoo dot com
There is no workaround.
imap_mail simply take the rpath and put it in from-header.
Its impossible for me to get error information back.
 [2004-12-27 22:37 UTC] sirber at gmail dot com
The only "workaround" is to use SMTP with sockets directly.
 [2005-01-19 14:37 UTC] sniper@php.net
Use mail() function. It is much more flexible and does exactly same things as imap_mail().

Please ask further support questions on how to configure your system properly on the proper mailing list(s) found at  http://www.php.net/mailing-lists.php



 [2010-03-20 21:46 UTC] mvanbeek at supporting-role dot co dot uk
If this bug is not going to be fixed, then the parameter should be removed from the function, or the function should become a wrapper for mail().
 [2011-08-04 16:18 UTC] pajoye@php.net
The following patch has been added/updated:

Patch Name: Patch-by-Keloran-ava3ar-at-gmail-com
Revision:   1312474732
URL:        https://bugs.php.net/patch-display.php?bug=30688&patch=Patch-by-Keloran-ava3ar-at-gmail-com&revision=1312474732
 [2011-08-04 20:44 UTC] ava3ar at gmail dot com
There ya go patched it for you, can be pack ported to 5.3 if needed

thanks to pajoye for putting patch on

this patch has only been tested on amd64, so no idea if it will work on x86 or 
other, but i dont see a reason it wont work on x86
 [2012-07-07 20:03 UTC] stas@php.net
Could you please address the comments on the pull by Johannes?
 [2012-07-07 20:03 UTC] stas@php.net
-Status: Wont fix +Status: Feedback
 [2013-02-18 00:09 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 00:01:27 2019 UTC