php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30671 "Unable to fork..."-error appears periodically
Submitted: 2004-11-03 13:36 UTC Modified: 2004-11-17 09:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: henning dot mohren at gmx dot de Assigned:
Status: Wont fix Package: Filesystem function related
PHP Version: 5.0.2 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
18 + 46 = ?
Subscribe to this entry?

 
 [2004-11-03 13:36 UTC] henning dot mohren at gmx dot de
Description:
------------
Solaris restricts the use of popen() to 255 files, which is a low limit in case of servers. When using PHP's system() commands, PHP calls Solaris popen(). This fails, when too system-commands have been invoked.
See here (http://www.sitepoint.com/forums/showthread.php?p=1245879#post1245879) for more details.

Expected result:
----------------
PHP should implement a workaround or call another Solaris function for invoking system commands.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-11-17 09:22 UTC] tony2001@php.net
Tune your Solaris instead. 
Values of rlim_fd_max and rlim_fd_cur can be changed with appropriate settings in /etc/system.
I doubt that PHP can implement any workaround for OS limit.
 [2011-10-28 21:59 UTC] jtm dot moon dot forum dot user at gmail dot com
This works for me.  php running within Apache (process name "httpd").
    sudo plimit -n 65536,1048575 $(pgrep 'httpd')
This increases the integer values allowed for new file descriptors.
 [2011-11-16 01:21 UTC] jtm dot moon dot forum dot user at gmail dot com
My previous comment about the plimit workround does not seem to be working consistently.  It worked for about 10 minutes and then I ran into problems again.  The process forks are only happening once or twice a minute.  So it's not that the new range for FD was used up within 10 minutes.

The only thing that seems to work is waiting a few minutes.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 22:01:26 2019 UTC