php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30631 /usr/libexec/elf/ld: Warning: size of symbol `strxmov' changed from 52 to 42
Submitted: 2004-10-31 19:02 UTC Modified: 2004-12-21 08:01 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mailbox at 2fresh dot ru Assigned: georg (profile)
Status: Closed Package: Compile Warning
PHP Version: 5.0.2 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
26 + 26 = ?
Subscribe to this entry?

 
 [2004-10-31 19:02 UTC] mailbox at 2fresh dot ru
Description:
------------
compile PHP5.0.2 + MySQL 4.1.7-standard


-bash-2.05b$ ./configure --prefix=/home/u12613/usr/local/ --with-zlib --with-mysql=/home/u12613/usr/local --with-mysql-sock=/home/u12613/tmp --with-mysqli=/home/u12613/usr/local/bin/mysql_config --enable-embedded-mysqli


configure ok

make errors:


Reproduce code:
---------------
...
/home/u12613/usr/local/lib/libmysqlclient.a(strmake.o)(.text+0x0): first defined here
/usr/libexec/elf/ld: Warning: size of symbol `strmake' changed from 49 to 48 in /home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o)
/home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o): In function `strnmov':
libmystrings_strings-x86.o(.text+0x1a6): multiple definition of `strnmov'
/home/u12613/usr/local/lib/libmysqlclient.a(strnmov.o)(.text+0x0): first defined here
/usr/libexec/elf/ld: Warning: size of symbol `strnmov' changed from 46 to 32 in /home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o)
/home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o): In function `strmov':
libmystrings_strings-x86.o(.text+0x1c6): multiple definition of `strmov'
/home/u12613/usr/local/lib/libmysqlclient.a(strmov.o)(.text+0x0): first defined here
/home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o): In function `strxmov':
libmystrings_strings-x86.o(.text+0x1e1): multiple definition of `strxmov'
/home/u12613/usr/local/lib/libmysqlclient.a(strxmov.o)(.text+0x0): first defined here
/usr/libexec/elf/ld: Warning: size of symbol `strxmov' changed from 52 to 42 in /home/u12613/usr/local/lib/libmysqld.a(libmystrings_strings-x86.o)
*** Error code 1


Actual result:
--------------
whats problem?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-31 19:47 UTC] mailbox at 2fresh dot ru
hmm..., without --enable-embedded-mysqli

everything is ok.
 [2004-10-31 20:07 UTC] helly@php.net
That's because ext/mysql links to a different version of the mysql client.
 [2004-10-31 20:14 UTC] mailbox at 2fresh dot ru
ok. 5.0.2 is not friends with mysql MySQL 4.1.7?
 [2004-10-31 20:25 UTC] helly@php.net
No you didn't read what i wrote.

ext/mysql links to the normal mysqlclient lib.

By specifying --with-embedded-mysqli extension mysqli links to mysqld lib. And those two cannot be linked into one target.

That means you can have ext/mysql, ext/mysqli, ext/pdo_mysql and ext/pdo_mysqli (once it's ready) as long as you do not use embedded version of mysql. If you do you can still use ext/mysqli and ext/pdo_mysqli (once it's ready).
 [2004-10-31 20:33 UTC] mailbox at 2fresh dot ru
ok! big thnx!
 [2004-10-31 20:53 UTC] helly@php.net
Reopen: Still we may *want* to be able to link ext/mysql when using embedded version.
 [2004-12-21 08:01 UTC] sniper@php.net
No we don't.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 09:05:54 2022 UTC