php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30555 An html file sent from a Win XP SP2 pc is recognized as a text file
Submitted: 2004-10-26 03:53 UTC Modified: 2004-10-26 19:38 UTC
From: onepiece at fanfic-fr dot net Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.9 OS: WIN XP PRO SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
44 - 32 = ?
Subscribe to this entry?

 
 [2004-10-26 03:53 UTC] onepiece at fanfic-fr dot net
Description:
------------
Server:
OS: WIN XP PRO SP1
Apache: Apache 2.0.52
PHP: php 4.3.9
Mysql: 2.5.3

This happends only on computers with SP2 applied.
(SP1 do not have this problem)
[This looks like bug #10294 which was for RH).

When sending a html file (generated by Word) through a form using the POST method from a client (Win XP Pro SP2) to the server, the $_FILES["file"]["type"] returns a type of "text/plain" instead of "text/html".

This has been verified with at least three computers tested before and after SP2.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-26 09:04 UTC] derick@php.net
Blame Microsoft.
 [2004-10-26 19:37 UTC] onepiece at fanfic-fr dot net
C'est MySQL 4.1.4 et non 2.5.3
 [2004-10-26 19:38 UTC] onepiece at fanfic-fr dot net
This is MySQL 4.1.4, not 2.5.3
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 24 09:05:44 2022 UTC