php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30550 Configuration problem while compiling-in mnoGoSearch with MySQL support
Submitted: 2004-10-25 14:37 UTC Modified: 2004-10-30 13:17 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: noor at comrax dot com Assigned: gluke (profile)
Status: Not a bug Package: mnoGoSearch related
PHP Version: 4.3.9 OS: FreeBSD 4.9-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: noor at comrax dot com
New email:
PHP Version: OS:

 

 [2004-10-25 14:37 UTC] noor at comrax dot com
Description:
------------
I'm trying to build Apache with mod_ssl support, with PHP+MySQL as module with mnoGoSearch+MySQL.

After building mnoGoSearch with no problem, I move on to building the rest of the packages: Apache, mod_ssl and PHP.

The following presents what happens during this.

Reproduce code:
---------------
Installtion of mnoGoSearch:
***************************
I installed mnoGoSearch in /usr/local/mnogosearch regularly with the following configure command line:

    ./configure --prefix=/usr/local/mnogosearch --bindir=/usr/local/mnogosearch/bin --sbindir=/usr/local/mnogosearch/sbin --sysconfdir=/usr/local/mnogosearch/etc --localstatedir=/usr/local/mnogosearch/var --libdir=/usr/local/mnogosearch/lib --includedir=/usr/local/mnogosearch/include --mandir=/usr/local/mnogosearch/man --enable-shared --disable-static --enable-syslog --enable-parser --enable-mp3 --enable-file --enable-http --enable-ftp --enable-htdb --enable-news --with-mysql=/usr/local/mysql --enable-freebsd-pthreads

The configuration and compilation of mnoGoSearch passes with no aparent problem. I then use it to index a website with no problem.

Next, I extract three packages, each in its own directory:

    apache_1.3.32/
    mod_ssl-2.8.21-1.3.32/
    php-4.3.9/

Preparation of Installtion of Apache:
*************************************
Next, I go into apache_1.3.32/ and type:

    ./configure

This runs smoothly in preparation of PHP's later-on compilation.

Installtion of mod_ssl:
***********************
Next, I go into mod_ssl-2.8.21-1.3.32/ and type:

    ./configure --enable-shared --with-apache=../apache_1.3.32

This, also, runs smoothly and prepares mod_ssl module in Apache's src/ directory.

Installtion of PHP:
*******************
Next, I go into php-4.3.9/ and type:

    ./configure --prefix=/usr/local --without-pear --disable-cli --disable-debug --disable-cgi --with-xml --enable-bcmath --enable-trans-sid --enable-track-vars --enable-discard-path --with-ftp --with-gd=/usr/local --with-ttf=/usr/local --with-zlib=/usr --with-jpeg-dir=/usr/local --with-mnogosearch --with-mysql=/usr/local/mysql --with-regex=php --enable-sysvsem --enable-sysvshm --enable-shmop --enable-memory-limit --with-config-file-path=/www/etc --with-apache=../apache_1.3.32

Now, here comes the problem! After running for few seconds, configure spits out the following error:

.
.
.
checking whether time.h and sys/time.h may both be included... yes
checking for uid_t in sys/types.h... (cached) yes
checking for type ulong... no
checking for type uchar... no
checking for type uint... no
checking for type ushort... no
checking for int8... no
checking base type of last arg to accept... socklen_t
checking return type of qsort... void
checking for mysql_close in -lmysqlclient... no
checking for mysql_error in -lmysqlclient... no
configure: error: mysql configure failed. Please check config.log for more information.

This has been the case in two servers -- one running MySQL version 12.22 Distrib 4.0.21, and another running MySQL version 14.6 Distrib 4.1.4-gamma. The same scenario happens in both servers. Furthermore, the same scenario happens with PHP 4.3.7 as well.


Expected result:
----------------
N/A

Actual result:
--------------
N/A

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-25 14:41 UTC] noor at comrax dot com
config.log has the following:
__________________________________________________________

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:1638: checking host system type
configure:1726: checking for gcc
configure:1839: checking whether the C compiler (gcc  ) works
configure:1855: gcc -o conftest    conftest.c  1>&5
configure:1881: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1886: checking whether we are using GNU C
configure:1895: gcc -E conftest.c
configure:1914: checking whether gcc accepts -g
configure:1947: checking whether gcc and cc understand -c and -o together
configure:1962: gcc -c conftest.c -o conftest.o 1>&5
configure:1963: gcc -c conftest.c -o conftest.o 1>&5
configure:1968: cc -c conftest.c 1>&5
configure:1970: cc -c conftest.c -o conftest.o 1>&5
configure:1971: cc -c conftest.c -o conftest.o 1>&5
configure:1998: checking how to run the C preprocessor
configure:2019: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:2079: checking for AIX
configure:2106: checking if compiler supports -R
configure:2121: gcc -o conftest -g -O2   conftest.c -R /usr/lib  1>&5
configure:2180: checking for re2c
configure:2211: checking for ranlib
configure:2239: checking whether ln -s works
configure:2264: checking for mawk
configure:2264: checking for gawk
configure:2264: checking for nawk
configure:2298: checking for bison
configure:2298: checking for byacc
configure:2342: checking for flex
configure:2376: checking for yywrap in -lfl
configure:2395: gcc -o conftest -g -O2   conftest.c -lfl   1>&5
configure:2419: checking lex output file root
configure:2440: checking whether yytext is a pointer
configure:2459: gcc -o conftest -g -O2   conftest.c  -lfl 1>&5
configure:2483: checking for working const
configure:2537: gcc -c -g -O2  conftest.c 1>&5
configure:2562: checking flex version
configure:2706: gcc -o conftest -g -O2   conftest.c  1>&5
/tmp/ccsHihEv.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:2702: undefined reference to `pthread_mutexattr_init'
/tmp/install/COMPILE/php-4.3.9/configure:2703: undefined reference to `pthread_create'
configure: failed program was:
#line 2688 "configure"
#include "confdefs.h"

#include <pthread.h>
#include <stddef.h>

void *thread_routine(void *data) {
    return data;
}

int main() {
    pthread_t thd;
    pthread_mutexattr_t mattr;
    int data = 1;
    pthread_mutexattr_init(&mattr);
    return pthread_create(&thd, NULL, thread_routine, &data);
}
configure:2726: checking for pthreads_cflags
configure:2759: gcc -o conftest -g -O2 -kthread   conftest.c  1>&5
gcc: unrecognized option `-kthread'
/tmp/cc5PNepb.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:2755: undefined reference to `pthread_mutexattr_init'
/tmp/install/COMPILE/php-4.3.9/configure:2756: undefined reference to `pthread_create'
configure: failed program was:
#line 2741 "configure"
#include "confdefs.h"

#include <pthread.h>
#include <stddef.h>

void *thread_routine(void *data) {
    return data;
}

int main() {
    pthread_t thd;
    pthread_mutexattr_t mattr;
    int data = 1;
    pthread_mutexattr_init(&mattr);
    return pthread_create(&thd, NULL, thread_routine, &data);
}
configure:2759: gcc -o conftest -g -O2 -pthread   conftest.c  1>&5
configure:2789: checking for pthreads_lib
configure:2915: checking for AOLserver support
configure:3135: checking for Apache 1.x module support via DSO through APXS
configure:3418: checking for Apache 1.x module support
configure:4199: checking for member fd in BUFF *
configure:4218: gcc -c -g -O2  -I/tmp/install/COMPILE/apache_1.3.32/src/include -I/tmp/install/COMPILE/apache_1.3.32/src/os/unix conftest.c 1>&5
configure:4242: checking for mod_charset compatibility option
configure:4266: checking whether gcc supports -rdynamic
configure:4309: checking for Apache 2.0 filter-module support via DSO through APXS
configure:5045: checking for Apache 2.0 handler-module support via DSO through APXS
configure:5782: checking for Caudium support
configure:6092: checking for CLI build
configure:6152: checking for embedded SAPI library support
configure:6335: checking for Zeus ISAPI support
configure:6545: checking for NSAPI support
configure:6866: checking for PHTTPD support
configure:7075: checking for Pi3Web support
configure:7384: checking for Roxen/Pike support
configure:7633: checking for Servlet support
configure:8111: checking for thttpd
configure:8317: checking for TUX
configure:8531: checking for webjames
configure:8932: checking for chosen SAPI module
configure:9837: checking for missing declarations of reentrant functions
configure:9846: gcc -c -g -O2  conftest.c 1>&5
configure:9871: gcc -c -g -O2  conftest.c 1>&5
configure:9896: gcc -c -g -O2  conftest.c 1>&5
configure:9921: gcc -c -g -O2  conftest.c 1>&5
configure:9946: gcc -c -g -O2  conftest.c 1>&5
configure:9970: checking for sendmail
configure:10011: checking whether system uses EBCDIC
configure:10030: gcc -o conftest -g -O2   conftest.c  1>&5
configure: failed program was:
#line 10022 "configure"
#include "confdefs.h"

int main(void) {
  return (unsigned char)'A' != (unsigned char)0xC1;
}

configure:10104: checking for socket
configure:10132: gcc -o conftest -g -O2   conftest.c  1>&5
configure:10361: checking for htonl
configure:10389: gcc -o conftest -g -O2   conftest.c  1>&5
configure:10618: checking for gethostname
configure:10646: gcc -o conftest -g -O2   conftest.c  1>&5
configure:10875: checking for gethostbyaddr
configure:10903: gcc -o conftest -g -O2   conftest.c  1>&5
configure:11132: checking for yp_get_default_domain
configure:11160: gcc -o conftest -g -O2   conftest.c  1>&5
configure:11390: checking for dlopen
configure:11418: gcc -o conftest -g -O2   conftest.c  1>&5
configure:11648: checking for sin in -lm
configure:11667: gcc -o conftest -g -O2   conftest.c -lm   1>&5
configure:11660: warning: conflicting types for built-in function `sin'
configure:11701: checking for res_search
configure:11729: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:12237: checking for inet_aton
configure:12265: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:12633: checking for dn_skipname
configure:12661: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/cc7iinpY.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:12658: undefined reference to `dn_skipname'
configure: failed program was:
#line 12638 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char dn_skipname(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dn_skipname();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_dn_skipname) || defined (__stub___dn_skipname)
choke me
#else
dn_skipname();
#endif

; return 0; }
configure:12679: checking for __dn_skipname
configure:12707: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:13027: checking for ANSI C header files
configure:13040: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13107: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:13135: checking for dirent.h that defines DIR
configure:13148: gcc -c -g -O2  conftest.c 1>&5
configure:13173: checking for opendir in -ldir
configure:13192: gcc -o conftest -g -O2   conftest.c -ldir  -lm  1>&5
/usr/libexec/elf/ld: cannot find -ldir
configure: failed program was:
#line 13181 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char opendir();

int main() {
opendir()
; return 0; }
configure:13258: checking for fclose declaration
configure:13267: gcc -c -g -O2  conftest.c 1>&5
configure:13342: checking for dirent.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for ApplicationServices/ApplicationServices.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: ApplicationServices/ApplicationServices.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <ApplicationServices/ApplicationServices.h>
configure:13342: checking for sys/param.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/types.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/time.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for netinet/in.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for alloca.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: alloca.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <alloca.h>
configure:13342: checking for arpa/inet.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for arpa/nameser.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for assert.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for crypt.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: crypt.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <crypt.h>
configure:13342: checking for fcntl.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for grp.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for ieeefp.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for langinfo.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for limits.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for locale.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for monetary.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: monetary.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <monetary.h>
configure:13342: checking for mach-o/dyld.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: mach-o/dyld.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <mach-o/dyld.h>
configure:13342: checking for netdb.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for pwd.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for resolv.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for signal.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for stdarg.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for stdlib.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for string.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for syslog.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sysexits.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/file.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/mman.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/mount.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/poll.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/resource.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/select.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/socket.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/statfs.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: sys/statfs.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <sys/statfs.h>
configure:13342: checking for sys/statvfs.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: sys/statvfs.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <sys/statvfs.h>
configure:13342: checking for sys/vfs.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: sys/vfs.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <sys/vfs.h>
configure:13342: checking for sys/sysexits.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: sys/sysexits.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <sys/sysexits.h>
configure:13342: checking for sys/varargs.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: sys/varargs.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <sys/varargs.h>
configure:13342: checking for sys/wait.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for unistd.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for unix.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13348: unix.h: No such file or directory
configure: failed program was:
#line 13347 "configure"
#include "confdefs.h"
#include <unix.h>
configure:13342: checking for utime.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/utsname.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for sys/ipc.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13342: checking for dlfcn.h
configure:13352: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:13381: checking for fopencookie
configure:13409: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccol6dSr.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:13406: undefined reference to `fopencookie'
configure: failed program was:
#line 13386 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char fopencookie(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char fopencookie();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_fopencookie) || defined (__stub___fopencookie)
choke me
#else
fopencookie();
#endif

; return 0; }
configure:13553: checking for broken getcwd
configure:13568: checking for broken libc stdio
configure:13629: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:13657: checking whether struct tm is in sys/time.h or time.h
configure:13670: gcc -c -g -O2  conftest.c 1>&5
configure:13691: checking for tm_zone in struct tm
configure:13704: gcc -c -g -O2  conftest.c 1>&5
configure:13763: checking for tm_gmtoff in struct tm
configure:13776: gcc -c -g -O2  conftest.c 1>&5
configure:13799: checking for struct flock
configure:13814: gcc -c -g -O2  conftest.c 1>&5
configure:13841: checking for socklen_t
configure:13858: gcc -c -g -O2  conftest.c 1>&5
configure:13884: checking size of long
configure:13903: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:13923: checking size of int
configure:13942: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:13963: checking for st_blksize in struct stat
configure:13976: gcc -c -g -O2  conftest.c 1>&5
configure:13998: checking for st_blocks in struct stat
configure:14011: gcc -c -g -O2  conftest.c 1>&5
configure:14038: checking for st_rdev in struct stat
configure:14051: gcc -c -g -O2  conftest.c 1>&5
configure:14073: checking for size_t
configure:14106: checking for uid_t in sys/types.h
configure:14141: checking for struct sockaddr_storage
configure:14154: gcc -c -g -O2  conftest.c 1>&5
configure:14186: gcc -c -g -O2  conftest.c 1>&5
configure:14199: checking for IPv6 support
configure:14213: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14231: checking for vprintf
configure:14259: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for alphasort
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for asctime_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for chroot
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for ctime_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for cuserid
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccxoeQOH.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: undefined reference to `cuserid'
configure: failed program was:
#line 14408 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char cuserid(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char cuserid();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_cuserid) || defined (__stub___cuserid)
choke me
#else
cuserid();
#endif

; return 0; }
configure:14403: checking for crypt
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccC56E3J.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: undefined reference to `crypt'
configure: failed program was:
#line 14408 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char crypt(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char crypt();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_crypt) || defined (__stub___crypt)
choke me
#else
crypt();
#endif

; return 0; }
configure:14403: checking for flock
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for ftok
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for funopen
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for gai_strerror
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for gcvt
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccKuVyg0.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: undefined reference to `gcvt'
configure: failed program was:
#line 14408 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char gcvt(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gcvt();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_gcvt) || defined (__stub___gcvt)
choke me
#else
gcvt();
#endif

; return 0; }
configure:14403: checking for getlogin
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for getprotobyname
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for getprotobynumber
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for getservbyname
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for getservbyport
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for getrusage
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for gettimeofday
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for gmtime_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for isascii
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for link
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for localtime_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for lockf
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for lrand48
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for memcpy
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14415: warning: conflicting types for built-in function `memcpy'
configure:14403: checking for memmove
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for mkstemp
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for mmap
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for nl_langinfo
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for perror
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for poll
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for putenv
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for realpath
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for random
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for rand_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for regcomp
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for res_search
configure:14403: checking for scandir
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for setitimer
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for setlocale
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for localeconv
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for setsockopt
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for setvbuf
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for shutdown
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for sin
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14415: warning: conflicting types for built-in function `sin'
configure:14403: checking for snprintf
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for srand48
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for srandom
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for statfs
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for statvfs
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/cci84w93.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: undefined reference to `statvfs'
configure: failed program was:
#line 14408 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char statvfs(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char statvfs();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_statvfs) || defined (__stub___statvfs)
choke me
#else
statvfs();
#endif

; return 0; }
configure:14403: checking for std_syslog
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccxwrcbu.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: undefined reference to `std_syslog'
configure: failed program was:
#line 14408 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char std_syslog(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char std_syslog();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_std_syslog) || defined (__stub___std_syslog)
choke me
#else
std_syslog();
#endif

; return 0; }
configure:14403: checking for strcasecmp
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strcoll
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strdup
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strerror
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strftime
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strstr
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for strtok_r
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for symlink
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for tempnam
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
/tmp/ccA9toD9.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:14428: warning: tempnam() possibly used unsafely; consider using mkstemp()
configure:14403: checking for tzset
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for unsetenv
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for usleep
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for utime
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14403: checking for vsnprintf
configure:14431: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14457: checking for getaddrinfo
configure:14469: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14512: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure: In function `main':
configure:14485: `NULL' undeclared (first use in this function)
configure:14485: (Each undeclared identifier is reported only once
configure:14485: for each function it appears in.)
configure:14496: `AF_INET' undeclared (first use in this function)
configure:14500: dereferencing pointer to incomplete type
configure: failed program was:
#line 14475 "configure"
#include "confdefs.h"

#include <netdb.h>
#include <sys/types.h>
int main(void) {
  struct addrinfo *ai, *pai, hints;

  memset(&hints, 0, sizeof(hints));
  hints.ai_flags = AI_NUMERICHOST;

  if (getaddrinfo("127.0.0.1", NULL, &hints, &ai) < 0) {
    exit(1);
  }

  if (ai == NULL) {
    exit(1);
  }

  pai = ai;

  while (pai) {
    if (pai->ai_family != AF_INET) {
      /* 127.0.0.1/NUMERICHOST should only resolve ONE way */
      exit(1);
    }
    if (pai->ai_addr->sa_family != AF_INET) {
      /* 127.0.0.1/NUMERICHOST should only resolve ONE way */
      exit(1);
    }
    pai = pai->ai_next;
  }
  freeaddrinfo(ai);
  exit(0);
}

configure:14544: checking for strlcat
configure:14572: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14544: checking for strlcpy
configure:14572: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14544: checking for getopt
configure:14572: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14599: checking whether utime accepts a null argument
configure:14620: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14646: checking for working alloca.h
configure:14679: checking for alloca
configure:14712: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14879: checking whether sprintf is broken
configure:14894: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14928: checking whether snprintf is broken
configure:14958: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:14992: checking for declared timezone
configure:15013: gcc -c -g -O2  conftest.c 1>&5
configure:15039: checking for type of reentrant time-related functions
configure:15068: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure: In function `main':
configure:15060: warning: assignment makes integer from pointer without a cast
configure:15061: too many arguments to function `asctime_r'
configure: failed program was:
#line 15050 "configure"
#include "confdefs.h"

#include <time.h>

main() {
char buf[27];
struct tm t;
time_t old = 0;
int r, s;

s = gmtime_r(&old, &t);
r = (int) asctime_r(&t, buf, 26);
if (r == s && s == 0) return (0);
return (1);
}

configure:15098: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure: In function `main':
configure:15091: too many arguments to function `asctime_r'
configure: failed program was:
#line 15082 "configure"
#include "confdefs.h"

#include <time.h>
main() {
  struct tm t, *s;
  time_t old = 0;
  char buf[27], *p;

  s = gmtime_r(&old, &t);
  p = asctime_r(&t, buf, 26);
  if (p == buf && s == &t) return (0);
  return (1);
}

configure:15136: checking for readdir_r
configure:15164: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:15186: checking for type of readdir_r
configure:15222: gcc -o conftest -g -O2   conftest.c -lm  1>&5
configure:15340: checking whether to include debugging symbols
configure:15373: checking layout of installed files
configure:15407: checking path to configuration file
configure:15443: checking directory to be scanned for configuration files
configure:15473: checking whether to enable safe mode by default
configure:15508: checking for safe mode exec dir
configure:15549: checking whether to enable PHP's own SIGCHLD handler
configure:15586: checking whether to enable magic quotes by default
configure:15623: checking whether to enable runpaths
configure:15648: checking whether to explicitly link against libgcc
configure:15727: checking whether to enable short tags by default
configure:15764: checking whether to enable dmalloc
configure:15852: checking whether to enable IPv6 support
configure:15882: checking whether to enable versioning
configure:15934: checking for OpenSSL support
configure:16832: checking for ZLIB support
configure:16878: checking if the location of ZLIB install directory is defined
configure:17219: checking for gzgets in -lz
configure:17238: gcc -o conftest -g -O2   conftest.c -lz  -lm  1>&5
configure:17376: checking whether to enable bc style precision math functions
configure:17658: checking for BZip2 support
configure:18204: checking whether to enable calendar conversion support
configure:18469: checking for cpdflib support
configure:19506: checking for CRACKlib support
configure:19917: checking whether to enable ctype functions
configure:20180: checking for CURL support
configure:20959: checking for cyrus imap support
configure:21872: checking for xDBM support
configure:22491: checking whether to enable DBA
configure:22817: checking for GDBM support
configure:23122: checking for NDBM support
configure:23421: checking for Berkeley DB4 support
configure:23741: checking for Berkeley DB3 support
configure:24061: checking for Berkeley DB2 support
configure:24381: checking for DBM support
configure:24722: checking for CDB support
configure:24776: checking for INI File support
configure:24830: checking for FlatFile support
configure:24845: checking whether to enable DBA interface
configure:25088: checking whether to enable dbase support
configure:25351: checking whether to enable dbx support
configure:25610: checking whether to enable direct I/O support
configure:25871: checking for DOM support
configure:26532: checking for DOM XSLT support
configure:26557: checking for DOM EXSLT support
configure:27200: checking whether to enable EXIF (metadata from images) support
configure:27463: checking for FrontBase SQL92 (fbsql) support
configure:27885: checking for FDF support
configure:28597: checking whether to enable the bundled filePro support
configure:28860: checking for FriBidi support
configure:29303: checking whether to enable FTP support
configure:29567: checking for GD support
configure:29614: checking for the location of libjpeg
configure:29641: checking for the location of libpng
configure:29694: checking for the location of libXpm
configure:29719: checking for FreeType 1.x support
configure:29744: checking for FreeType 2
configure:29769: checking for T1lib support
configure:29794: checking whether to enable truetype string function in GD
configure:29819: checking whether to enable JIS-mapped Japanese font support in GD
configure:31821: checking for jpeg_read_header in -ljpeg
configure:31840: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  conftest.c -ljpeg  -lz -lm  1>&5
configure:33576: checking for gdImageString16 in -lgd
configure:33595: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:33707: checking for gdImagePaletteCopy in -lgd
configure:33726: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:33838: checking for gdImageCreateFromPng in -lgd
configure:33857: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:33969: checking for gdImageCreateFromGif in -lgd
configure:33988: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:34100: checking for gdImageGif in -lgd
configure:34119: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccO3ObSi.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:34116: undefined reference to `gdImageGif'
configure: failed program was:
#line 34108 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageGif();

int main() {
gdImageGif()
; return 0; }
configure:34231: checking for gdImageWBMP in -lgd
configure:34250: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:34362: checking for gdImageCreateFromJpeg in -lgd
configure:34381: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:34493: checking for gdImageCreateFromXpm in -lgd
configure:34512: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:34624: checking for gdImageCreateFromGd2 in -lgd
configure:34643: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:34755: checking for gdImageCreateTrueColor in -lgd
configure:34774: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccEHJYEK.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:34771: undefined reference to `gdImageCreateTrueColor'
configure: failed program was:
#line 34763 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageCreateTrueColor();

int main() {
gdImageCreateTrueColor()
; return 0; }
configure:34886: checking for gdImageSetTile in -lgd
configure:34905: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35017: checking for gdImageEllipse in -lgd
configure:35036: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccPbCqOq.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:35033: undefined reference to `gdImageEllipse'
configure: failed program was:
#line 35025 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageEllipse();

int main() {
gdImageEllipse()
; return 0; }
configure:35148: checking for gdImageSetBrush in -lgd
configure:35167: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35279: checking for gdImageStringTTF in -lgd
configure:35298: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35410: checking for gdImageStringFT in -lgd
configure:35429: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35541: checking for gdImageStringFTEx in -lgd
configure:35560: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/cclRk42h.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:35557: undefined reference to `gdImageStringFTEx'
configure: failed program was:
#line 35549 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageStringFTEx();

int main() {
gdImageStringFTEx()
; return 0; }
configure:35672: checking for gdImageColorClosestHWB in -lgd
configure:35691: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35803: checking for gdImageColorResolve in -lgd
configure:35822: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:35934: checking for gdImageGifCtx in -lgd
configure:35953: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccmifgcB.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:35950: undefined reference to `gdImageGifCtx'
configure: failed program was:
#line 35942 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageGifCtx();

int main() {
gdImageGifCtx()
; return 0; }
configure:36065: checking for gdCacheCreate in -lgd
configure:36084: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:36196: checking for gdFontCacheShutdown in -lgd
configure:36215: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccybl8RP.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:36212: undefined reference to `gdFontCacheShutdown'
configure: failed program was:
#line 36204 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdFontCacheShutdown();

int main() {
gdFontCacheShutdown()
; return 0; }
configure:36327: checking for gdNewDynamicCtxEx in -lgd
configure:36346: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
/tmp/ccV7GkvE.o: In function `main':
/tmp/install/COMPILE/php-4.3.9/configure:36343: undefined reference to `gdNewDynamicCtxEx'
configure: failed program was:
#line 36335 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdNewDynamicCtxEx();

int main() {
gdNewDynamicCtxEx()
; return 0; }
configure:36415: gcc -c -g -O2 -I/usr/local/include/gd conftest.c 1>&5
configure: In function `main':
configure:36410: structure has no member named `gd_free'
configure: failed program was:
#line 36401 "configure"
#include "confdefs.h"

#include <gd.h>
#include <stdlib.h>

int main() {

gdIOCtx *ctx;
ctx = malloc(sizeof(gdIOCtx));
ctx->gd_free = 1;

; return 0; }
configure:36762: checking for gdImageCreate in -lgd
configure:36781: gcc -o conftest -g -O2  -R/usr/local/lib -L/usr/local/lib  -R/usr/local/lib -L/usr/local/lib conftest.c -lgd  -lgd -lttf -ljpeg -lz -lm  1>&5
configure:36827: checking for GNU gettext support
configure:37503: checking for GNU MP support
configure:38170: checking for hwapi support
configure:38832: checking for Hyperwave support
configure:39075: checking for iconv support
configure:40137: checking for IMAP support
configure:41412: checking for Informix support
configure:42000: checking for Ingres II support
configure:42508: checking for InterBase support
configure:43177: checking for IRCG support
configure:43658: checking for Java support
configure:44442: checking for LDAP support
configure:46813: checking whether to enable multibyte string support
configure:46859: checking whether to enable multibyte regex support
configure:46884: checking for external libmbfl
configure:47592: checking for MCAL support
configure:47989: checking for mcrypt support
configure:49097: checking for MCVE support
configure:49143: checking OpenSSL dir for MCVE
configure:50501: checking for mhash support
configure:50903: checking whether to include mime_magic support
configure:51188: checking for MING support
configure:51855: checking for mnoGoSearch support
configure:51911: checking for mnoGoSearch version
configure:52261: checking for msession support
configure:52647: checking for mSQL support
configure:53086: checking for MSSQL support via FreeTDS
configure:53700: checking for MySQL support
configure:53746: checking for specified location of the MySQL UNIX socket
configure:53803: checking for MySQL UNIX socket location
configure:55425: checking size of char
configure:55444: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 55433 "configure"
#include "confdefs.h"
#include <stdio.h>
main()
{
  FILE *f=fopen("conftestval", "w");
  if (!f) exit(1);
  fprintf(f, "%d\n", sizeof(char));
  exit(0);
}
configure:55465: checking size of int
configure:55504: checking size of long
configure:55543: checking size of long long
configure:55562: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 55551 "configure"
#include "confdefs.h"
#include <stdio.h>
main()
{
  FILE *f=fopen("conftestval", "w");
  if (!f) exit(1);
  fprintf(f, "%d\n", sizeof(long long));
  exit(0);
}
configure:55582: checking for size_t
configure:55615: checking whether time.h and sys/time.h may both be included
configure:55629: gcc -c -g -O2  conftest.c 1>&5
configure:55650: checking for uid_t in sys/types.h
configure:55685: checking for type ulong
configure:55704: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
configure: In function `main':
configure:55698: syntax error before `foo'
configure:55699: `foo' undeclared (first use in this function)
configure:55699: (Each undeclared identifier is reported only once
configure:55699: for each function it appears in.)
configure: failed program was:
#line 55693 "configure"
#include "confdefs.h"
#include <stdio.h>
#include <sys/types.h>
main()
{
  ulong foo;
  foo++;
  exit(0);
}
configure:55728: checking for type uchar
configure:55747: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
configure: In function `main':
configure:55741: syntax error before `foo'
configure:55742: `foo' undeclared (first use in this function)
configure:55742: (Each undeclared identifier is reported only once
configure:55742: for each function it appears in.)
configure: failed program was:
#line 55736 "configure"
#include "confdefs.h"
#include <stdio.h>
#include <sys/types.h>
main()
{
  uchar foo;
  foo++;
  exit(0);
}
configure:55771: checking for type uint
configure:55790: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 55779 "configure"
#include "confdefs.h"
#include <stdio.h>
#include <sys/types.h>
main()
{
  uint foo;
  foo++;
  exit(0);
}
configure:55814: checking for type ushort
configure:55833: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 55822 "configure"
#include "confdefs.h"
#include <stdio.h>
#include <sys/types.h>
main()
{
  ushort foo;
  foo++;
  exit(0);
}
configure:55857: checking for int8
configure:55887: gcc -o conftest -g -O2   -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
configure: In function `main':
configure:55881: syntax error before `i'
configure: failed program was:
#line 55865 "configure"
#include "confdefs.h"

#ifdef HAVE_STDLIB_H
#include <stdlib.h>
#endif

#ifdef HAVE_STDDEF_H
#include <stddef.h>
#endif

#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif

int main()
{
    int8 i;
    return 0;
}

configure:55913: checking base type of last arg to accept
configure:55941: g++ -c   conftest.C 1>&5
configure:55990: checking return type of qsort
configure:56008: gcc -c -g -O2  conftest.c 1>&5
configure:56360: checking for mysql_close in -lmysqlclient
configure:56379: gcc -o conftest -g -O2  -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql  -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib conftest.c -lmysqlclient  -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 56368 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char mysql_close();

int main() {
mysql_close()
; return 0; }
configure:56584: checking for mysql_error in -lmysqlclient
configure:56603: gcc -o conftest -g -O2  -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql  -R/usr/local/lib -L/usr/local/lib -R/usr/local/mysql/lib/mysql -L/usr/local/mysql/lib/mysql -R/usr/local/mnogosearch/lib -L/usr/local/mnogosearch/lib -R/usr -L/usr conftest.c -lmysqlclient  -lz -lgd -lttf -ljpeg -lz -lm  -lm -lz -lmysqlclient -lmnogosearch -lmnogocharset 1>&5
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_unlock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_destroy'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_lock'
/usr/local/mnogosearch/lib/libmnogosearch.so: undefined reference to `pthread_mutex_init'
configure: failed program was:
#line 56592 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char mysql_error();

int main() {
mysql_error()
; return 0; }
__________________________________________________________
 [2004-10-25 15:00 UTC] derick@php.net
This is a mnogosearch problem, the library is compiled against pthreads and PHP isn't taking that into account.
 [2004-10-25 15:19 UTC] noor at comrax dot com
This is incorrectly diagnosed.

Knowing that this might be a problem, I've compiled mnoGoSearch before with no pthread support (removed --enable-freebsd-pthreads at the end), re-compiled everything from scratch and went through the whole process. The same thing happens.
 [2004-10-27 22:54 UTC] gluke@php.net
This bug was fixed in the latest mnogosearch-cvs-3.2.24.
Wait a next mnogosearch release please.
 [2004-10-27 23:34 UTC] derick@php.net
So my diagnoses was correct. Not a bug in PHP -> bogus.
 [2004-10-30 13:11 UTC] noor at comrax dot com
I guess you were right after all. But what makes this all strange is that I did the same thing but with no threads support, and the thing stopped at the same spot...

Just curious why this might have happened.

Thanks for the quick and clean diagnosis, and of course the help.
 [2004-10-30 13:17 UTC] noor at comrax dot com
Hi again,

I just wanted to tell you that latest mnoGoSearch snapshot (mnogosearch-3.2.24-20041030) compiled fine, and that PHP 4.3.7 compiled fine as well.

<so-happy-now>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 16:01:27 2021 UTC