php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30515 unstandard mod_version/program_version signature in the apache modules
Submitted: 2004-10-21 18:16 UTC Modified: 2004-10-22 01:20 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mancini at users dot sourceforge dot net Assigned:
Status: Wont fix Package: Apache2 related
PHP Version: Irrelevant OS: win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mancini at users dot sourceforge dot net
New email:
PHP Version: OS:

 

 [2004-10-21 18:16 UTC] mancini at users dot sourceforge dot net
Description:
------------
all the apache php modules have allways printed only the program version as it's signature under the http server

the standard for all apache modules that are part of another software is the folowing format : 

mod_[name]/[modversion](space)[programname]/[programversion]

the format php uses is only : [programname]/[programversion]

for example the version 5.0.2 modules should show :
"mod_php5/5.0.2 PHP/5.0.2" but it shows only "PHP/5.0.2"

i take it that the version of the mod is the same as the one of the php release but that is not a reason for not compying for this facto standard

and here are some examples :

mod_perl/1.99_13-dev Perl/v5.8.3 
mod_python/3.1.3 Python/2.3.2 
mod_ssl/2.0.52 OpenSSL/0.9.7d




Reproduce code:
---------------
only the files mod_php5.c (line 902) and config.w32 (line 19) would need changing 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-21 22:24 UTC] jorton@php.net
But there is no separate mod_phpN project, there is just PHP.  It's useful to know both what version of mod_perl and what version of Perl is being used, hence the two version components.  But you're not going to be using "mod_php/4.3.9 PHP/5.0.2" exactly :) So, -> wontfix is appropriate for this.
 [2004-10-22 01:20 UTC] mancini at users dot sourceforge dot net
Ok then have it print only mod_php and version
As it is its not realy accurate since not PHP/5.0.2 is loaded into apache , mod_php5/5.0.2 is 

And how about the standard like i said and the people making a automated script based on that template
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 00:01:26 2019 UTC