php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30370 Server did not recognize the value of HTTP Header SOAPAction
Submitted: 2004-10-08 21:14 UTC Modified: 2004-11-16 14:20 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jfxberns at hotmail dot com Assigned: dmitry (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5.0.2 OS: Linux Fedora Core 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfxberns at hotmail dot com
New email:
PHP Version: OS:

 

 [2004-10-08 21:14 UTC] jfxberns at hotmail dot com
Description:
------------
php.ini-dist was copied directly to php.ini with no changes.

'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-soap' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--with-mysql' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'

I have another outstanding bug submitted ("Bug #30106  	SOAP cannot not parse 'ref' element. Causes Uncaught SoapFault exception.") that might be related, the other bug occurs whenI try to use WSDL to set up a SOAP client.  

Reproduce code:
---------------
  <?php
	$opts = array
	     ('location'     => 'http://www.precisionreservations.com/PRWebServ/getOtherInformation.asmx',
              'uri'          => 'urn:getOtherInformation');

	$parms = array
	         ('AFFILIATE_ID' => 'XXXX',
                  'PASSWORD'     => 'xxxxxxxx');

    $client = new SoapClient(NULL, $opts);

    $continents = $client->__call('getContinentList', $parms);

  ?>

(The line that starts with "$continents" is line 24 that PHP complains about.

Expected result:
----------------
$continents should be assigned an array of continents and their IDs.

Actual result:
--------------
Fatal error: Uncaught SoapFault exception: [soap:Client] Server did not recognize the value of HTTP Header SOAPAction: urn:getOtherInformation#getContinentList. in /usr/local/apache/htdocs/dh-bangkok/wstest/prtest-2.php:24 Stack trace: #0 {main} thrown in /usr/local/apache/htdocs/dh-bangkok/wstest/prtest-2.php on line 24

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-15 09:20 UTC] ashish dot sohane at nichelive dot com
Error :
 Server did not recognize the value of HTTP Header SOAPAction
 [2004-11-16 14:20 UTC] dmitry@php.net
This is not a bug.

If you don't use WSDL then you should specify "soapaction" by your self.


  $continents = $client->__call('getContinentList', $parms, 
    array("soapaction"=>"http://tempuri.org/PRWebServ/getOtherInformation/getContinentList"));

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC