|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30011 Installtion process of PHP 5.0.1 dies on AIX
Submitted: 2004-09-07 14:49 UTC Modified: 2004-12-29 01:00 UTC
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: bg at genetics dot agrsci dot dk Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.0.2 OS: aix
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: bg at genetics dot agrsci dot dk
New email:
PHP Version: OS:


 [2004-09-07 14:49 UTC] bg at genetics dot agrsci dot dk
During installation of PHP-5.0.1 on an IBM RS6000 with AIX the make process dies with the message

make: *** [install-pear-installer] Error 255

while executing

/h580/avl/bg/src/net/php-5.0.1/sapi/cli/php -n -dshort_open_tag=0 -dsafe_mode=0 /h580/avl/bg/src/net/php-5.0.1/pear/install-pear.php -d "/usr/local/lib/php" -b "/usr/local/bin" /h580/avl/bg/src/net/php-5.0.1/pear/package-*.xml 

Likewise make install-pear-packages dies with

make: *** [install-pear-packages] Error 255

Make is GNU make vers. 3.80.

The problem does not occur with PHP-4.3.8. PHP-4.3.8 compiled using essentially the same configuration works fine on the system.

The configuration of PHP is available at

Thank you for taking an interest!


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-23 15:59 UTC] bg at genetics dot agrsci dot dk
Just installed php-4.3.9 with the same configuration as before and the installation worked fine, while php-5.0.1 still doesn't work.
 [2004-09-30 16:50 UTC] Bjorn dot Wiberg at its dot uu dot se
This also happens on IBM AIX ML4 and with PHP 5.0.2:

root@spinus:/usr/local/src/php-5.0.2# /opt/freeware/bin/make install
Installing PHP SAPI module:       apache2handler
/apache/build/ SH_LIBTOOL='/apache/build/libtool' /apache/modules
rm -f /apache/modules/
/apache/build/libtool --mode=install cp /apache/modules/
cp .libs/ /apache/modules/
cp .libs/libphp5.lai /apache/modules/
libtool: install: warning: remember to run `libtool --finish /usr/local/src/php-5.0.2/libs'
chmod 755 /apache/modules/
[activating module `php5' in /apache/etc/httpd.conf]
Installing PHP CLI binary:        /apache/php/bin/
Installing PHP CLI man page:      /apache/php/man/man1/
Installing PEAR environment:      /apache/php/lib/php/
[PEAR] Archive_Tar    - installed: 1.1
[PEAR] Console_Getopt - installed: 1.2
[PEAR] PEAR           - installed: 1.3.2
Wrote PEAR system config file at: /apache/php/etc/pear.conf
You may want to add: /apache/php/lib/php to your php.ini include_path
make[1]: *** [install-pear-installer] Error 255
make: *** [install-pear] Error 2

PHP has been configured with (from config.nice):

CPPFLAGS='-I/usr/local/include' \
LDFLAGS='-L/lib -L/opt/freeware/lib -L/usr/local/lib' \
CC='/usr/local/bin/gcc' \
'./configure' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-dba' \
'--enable-exif' \
'--enable-embedded-mysqli' \
'--enable-filepro' \
'--enable-ftp' \
'--enable-gd-jis-conv' \
'--enable-gd-native-ttf' \
'--enable-mbstring' \
'--enable-memory-limit' \
'--enable-sockets' \
'--enable-versioning' \
'--enable-zend-multibyte' \
'--prefix=/apache/php' \
'--with-apxs2=/apache/bin/apxs' \
'--with-apxs2filter=/apache/bin/apxs' \
'--with-freetype-dir' \
'--with-gd' \
'--with-gdbm' \
'--with-gettext' \
'--with-inifile' \
'--with-jpeg-dir' \
'--with-ldap' \
'--with-libxml-dir' \
'--with-mime-magic' \
'--with-mnogosearch' \
'--with-mysql=/usr/local/mysql' \
'--with-openssl=/opt/freeware' \
'--with-png-dir' \
'--with-tiff-dir' \
'--with-ttf' \
'--with-xpm-dir' \
'--with-zlib' \

I'm using gcc (GCC) 3.3.2 and GNU Make 3.80 on an IBM eServer pSeries 615 (RS/6000) dual Power4-CPU machine.

Best regards,
 [2004-09-30 17:23 UTC] Bjorn dot Wiberg at its dot uu dot se
A simple workaround for this issue (until it gets resolved) could be adding "|| true" to the end of two targets "install-pear-installer" and "install-pear-packages"install-pear-installer in the Makefile: 

        @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) /usr/local/src/php-5.0.2/pear/install-pear.php -d "$(peardir)" -b "$(bindir)" /usr/local/src/php-5.0.2/pear/package-*.xml || true

install-pear-packages: $(top_builddir)/sapi/cli/php
        @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) /usr/local/src/php-5.0.2/pear/install-pear.php -d "$(peardir)" -b "$(bindir)" /usr/local/src/php-5.0.2/pear/packages/*.tar || true

Best regards,
 [2004-10-12 15:37 UTC] bg at genetics dot agrsci dot dk
Adding || true as suggested does allow PHP 5.0.2 to install.

Preliminary testing indicates that things otherwise are working, hence the installation problem is apparently not indicative of a deeper problem.

Best regards,

 [2004-11-05 16:08 UTC]
Please try using this CVS snapshot:
For Windows:

Antony might just have fixed this.
 [2004-12-01 15:03 UTC] bg at genetics dot agrsci dot dk
I just tried to install php5-STABLE-200411240730.

It did not resolve the issue.

Best regards,

 [2004-12-21 10:14 UTC]
Please try using this CVS snapshot:
For Windows:

 [2004-12-29 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 09:01:29 2024 UTC