php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3000 "System can't find .DLL - ODBC_32.DLL "
Submitted: 1999-12-18 17:22 UTC Modified: 2000-06-09 04:41 UTC
From: rik at shorebreak dot de Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Beta 3 OS: Win 95 b, Apache 1.3.9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rik at shorebreak dot de
New email:
PHP Version: OS:

 

 [1999-12-18 17:22 UTC] rik at shorebreak dot de
Well, PHP 4 Beta 2 runs fine!
But when I try to use Beta 3 Windows asks for an .DLL called ODBC_32.dll (or ODBC32.dll) although I dont have any ODBC stuff on my computer and also don't use it in the script.
Even the simple <?php phpinfo(); ?> causes this Windows Error.
in my php.ini only the MySQL DLL is uncommented (I have the PHP MySQLs and MySQL installed).

Please help.

Further I can't send forms - but with PHP 4 B2 and B3 (POST and GET)!
I guess it's an apache problem but i dont know much about apache.
I installed it with the install-guide of php.net and dynamic-webpages.de.
After i hit the send button i get an 500 Internal Server Error.

thanks.

rik

PS: Just a Question will I have to change all ...php3... entires to ...php4...?
like in "AddType application/x-httpd-php3 .php3" do i have to replace php3 with php4?
Will i have to change file-expression from php3 to php4?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-09 04:41 UTC] zeev at cvs dot php dot net
Have you installed the DCOM update from Microsoft?  It does a bit more than just updating DCOM...

http://download.microsoft.com/msdownload/dcom/95/x86/en/dcom95.exe

Either way, try to upgrade to PHP 4.0.0 release and see if the problem persists.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 13:05:46 2022 UTC