php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29926 display_errors setting ignored
Submitted: 2004-09-01 05:51 UTC Modified: 2004-09-01 14:32 UTC
From: scott at slerman dot net Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.0.1 OS: Fedora Core 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
11 + 5 = ?
Subscribe to this entry?

 
 [2004-09-01 05:51 UTC] scott at slerman dot net
Description:
------------
The php.ini setting display_errors seems to be ignored; no errors are displayed, even if display_errors is turned on.

Reproduce code:
---------------
<?php
echo ini_get("display_errors") . "<br/>";
echo $foo . "bar";
$foo[bar] = "phpinfo()";
?>

Expected result:
----------------
There should be warning messages about $foo being undefined and the constant "bar" being undefined.

Actual result:
--------------
Output is:
1
bar

As far as I know, the first line being 1 means that display_errors is on.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-01 08:00 UTC] philip@php.net
Which errors are shown (error level) has to do with error_reporting, not display_errors.
 [2004-09-01 14:32 UTC] scott at slerman dot net
Good point. I had checked phpinfo(), and it said error_reporting was 4095, so I figured it couldn't have been that. I discovered a .htaccess file that was setting error_reporting to 2048 (which, in my own defense, I don't remember ever creating). Will remember this next time.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 27 03:01:30 2024 UTC