php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29748 simplexml: tags doesn't exist crash my CLI or Apache
Submitted: 2004-08-19 02:27 UTC Modified: 2004-08-19 18:17 UTC
From: mesarpe at gmail dot com Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 5.0.1 OS: windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mesarpe at gmail dot com
New email:
PHP Version: OS:

 

 [2004-08-19 02:27 UTC] mesarpe at gmail dot com
Description:
------------
Hello! Well, I'm loadind an XML file into a file this xml has a parameter that doesn't exist. I try to readit, if it doesn't  exist, system shows me a windows messaged that CLI has crashed and my application will be closed. (I'm using Dev-PHP version alpha 3 http://devphp.sourceforge.net/)

I tryied to check it with Apache and my apache crash down too.

Thanks, anyway!

Reproduce code:
---------------
$var = @simplexml_load_file('xml.xml');
if($var->options->item == false)
 echo "a";
else
 echo "b";

Expected result:
----------------
a or b
a if it exist.
b if it doesn't

Actual result:
--------------
nothing

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-19 09:47 UTC] derick@php.net
We don't support dev-php.
 [2004-08-19 18:17 UTC] mesarpe at gmail dot com
It's not abvout Dev-PHP.... HAve you read it my description?

There's a bug, try to ue my code and you'll see
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 01:04:48 2022 UTC