|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29745 ftp_get warns on a Transfer Complete
Submitted: 2004-08-18 22:46 UTC Modified: 2005-03-15 01:00 UTC
Avg. Score:4.7 ± 0.6
Reproduced:9 of 9 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: pearcec at poss dot com Assigned:
Status: No Feedback Package: FTP related
PHP Version: 5.0.0 OS: RedHat ES3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
25 + 43 = ?
Subscribe to this entry?

 [2004-08-18 22:46 UTC] pearcec at poss dot com
I get a warning on a Transfer being complete...

Warning: ftp_get(): Transfer complete. in /home/pearcec/saturn/bin/sysNav/solarisPatchGrab/ on line 241

The problem is I am not running passive mode.  The ftp request times out and the file is 0 bugs.  It should have an error condition of times out.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-02 14:36 UTC] bazzymg at yahoo dot com
I'm running PHP/5.0.3RC1 under Apache 2.052 in WinXP, SP2.

I get the following warning messages:

Warning: ftp_get() [function.ftp-get]: Transfer complete - file {private - edited out} sent successfully in C:\Documents and Settings\Abu Hurayrah\Desktop\Web Development\TSI\ftp_test.php on line 45

DEBUG: There was an error retrieving and downloading file {private - edited out}

The filename DID have spaces in it - but it works on some, and not on others.  Go figure!  I suspect it might have something to do with timeout, because the first 114 files seem to have downloaded without error, and the files that couldn't be downloaded were the last ones.

I also realize I'm running a release candidate (forgot that I was), and I will update the shortly and see if it solves anything.
 [2005-02-02 14:53 UTC] bazzymg at yahoo dot com
Just to confirm, I have updated to the official release on PHP 5.0.3, and I am experiencing exactly the same errors.  Once again, my loadout is the following:

Apache/2.0.52 (Win32) PHP/5.0.3 WinXP SP2
 [2005-02-06 05:21 UTC] bazzymg at yahoo dot com
I tried it again on another machine, and this time, it did not happen - the only difference is that that machine doesn't have SP2, only SP1 (i.e., WinXP, Apache 2.052, PHP 5.0.3 ), so maybe SP2 is limiting connections, which I think is a "feature" they added.  I'll see if I can change that setting and get the problem solved.
 [2005-02-06 06:40 UTC] bazzymg at yahoo dot com
I've discovered that the cause of this bug, at least in my case, had to do with WinXP SP2 limiting the number of simultaneous connections per port to 10 per second, as a safety feature to prevent the spread of viruses/worms that attempt connections of this sort (i.e., searching for random IPs and trying to connect and exploit a weakness).

So, perhaps it is the case that this bug is caused by the system itself limiting connections in this manner.
 [2005-03-07 20:26 UTC]
Please try using this CVS snapshot:
For Windows:

 [2005-03-15 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 18 01:01:33 2024 UTC