php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29739 Error at libmysql.c:388
Submitted: 2004-08-18 17:42 UTC Modified: 2004-08-19 18:55 UTC
From: fmonna at generali dot es Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.8 OS: AIX 4.3.3 ML10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fmonna at generali dot es
New email:
PHP Version: OS:

 

 [2004-08-18 17:42 UTC] fmonna at generali dot es
Description:
------------
After a succefull configure, make fails to compile at libmysql.c:388

I'm using gcc. My configure command was:

./configure --with-mysql --with-apxs=/usr/HTTPServer/bin/apxs --with-gd --with-zlib-dir=/usr/local/lib --with-jpeg-dir=/usr/local/lib --with-png-dir=/usr/local/lib --with-xpm-dir=/usr/local/lib

Thanks for any help !!

Reproduce code:
---------------
make
        /bin/sh /tmp/php/php-4.3.8/libtool --silent --preserve-dup-deps --mode=compile gcc -I/tmp/php/php-4.3.8/ext/mysql/libmysql -Iext/mysql/ -I/tmp/php/php-4.3.8/ext/mysql/ -DPHP_ATOM_INC -I/tmp/php/php-4.3.8/include -I/tmp/php/php-4.3.8/main -I/tmp/php/php-4.3.8 -I/tmp/php/php-4.3.8/Zend -I/usr/local/include -I/tmp/php/php-4.3.8/ext/xml/expat  -I/tmp/php/php-4.3.8/TSRM  -O2  -prefer-pic -c /tmp/php/php-4.3.8/ext/mysql/libmysql/libmysql.c -o ext/mysql/libmysql/libmysql.lo
In file included from /tmp/php/php-4.3.8/ext/mysql/libmysql/libmysql.c:4:
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:260: warning: redefinition of `uint'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.2.0/3.0.1/include/sys/types.h:464: warning: `uint' previously declared here
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:261: warning: redefinition of `ushort'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.2.0/3.0.1/include/sys/types.h:463: warning: `ushort' previously declared here
In file included from /tmp/php/php-4.3.8/ext/mysql/libmysql/libmysql.c:4:
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:577: conflicting types for `int8'
/usr/include/sys/inttypes.h:622: previous declaration of `int8'
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:578: warning: redefinition of `int16'
/usr/include/sys/inttypes.h:623: warning: `int16' previously declared here
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:581: warning: redefinition of `uchar'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.2.0/3.0.1/include/sys/types.h:462: warning: `uchar' previously declared here
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:588: warning: redefinition of `int32'
/usr/include/sys/inttypes.h:624: warning: `int32' previously declared here
/tmp/php/php-4.3.8/ext/mysql/libmysql/global.h:601: warning: redefinition of `ulong'
/usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.2.0/3.0.1/include/sys/types.h:465: warning: `ulong' previously declared here
/tmp/php/php-4.3.8/ext/mysql/libmysql/libmysql.c: In function `net_field_length_ll':
/tmp/php/php-4.3.8/ext/mysql/libmysql/libmysql.c:388: warning: left shift count >= width of type
make: 1254-004 The error code from the last command is 1.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-19 18:43 UTC] fmonna at generali dot es
I could compile with no problems...

My lib paths were wrong. 

Thanks
 [2004-08-19 18:55 UTC] tony2001@php.net
Not a bug - > bogus.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 23 12:01:24 2020 UTC