php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29717 SMTP server not responding UNDER heavy mail() calls
Submitted: 2004-08-17 10:44 UTC Modified: 2004-08-17 15:49 UTC
From: mohammadb at future dot com dot lb Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.8 OS: Windows 2003
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mohammadb at future dot com dot lb
New email:
PHP Version: OS:

 

 [2004-08-17 10:44 UTC] mohammadb at future dot com dot lb
Description:
------------
I am using :
*) Windows 2003 Server
*) IIS 6.0 - Local SMTP Server
*) ISAPI PHP 4.3.8
*) MSSQL Server Standard Edition

My application is a voting application where it encounters heavy, heavy load (requests) in a short time (1 day) .

Under heavy load, the mail() funtion that I am using is not working or sending any Email. I dont know if the problem is from the ISAPI PHP(.dll) communicating with the SMTP server under heavy load OR from the SMTP Server itself.

THE mail() function works fine under low-medium load. BUT at a certain Peak requests for sending mails, my SMTP Server will not be responding and THE ONLY SOLUTION IS TO RESTART THE WHOLE IIS - then the mail() function starts to work.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-17 15:49 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

The problem is likely your mail server's load limit that 
cause it to start denying connection when a certain load is 
reached. 
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 14:01:31 2024 UTC