php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29673 Optimizing flag for gcc is wrong noted
Submitted: 2004-08-14 12:06 UTC Modified: 2004-08-16 08:44 UTC
From: bernhard at fuersten dot info Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4.3.8 OS: Darwin 7.5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bernhard at fuersten dot info
New email:
PHP Version: OS:

 

 [2004-08-14 12:06 UTC] bernhard at fuersten dot info
Description:
------------
The configure script checks for a working gcc -03 (zero-
three). This returns no error so it will configure the 
Makefile with

CFLAGS_CLEAN = -03

When running make the following warning will be produced 
in every line:

gcc: unrecognized option `-03'

After changing CFLAGS_CLEAN to -O3 (letter O and number 
three) it works.

Seems like the optimizing flag is wrong noted 
somewhere.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-16 08:44 UTC] derick@php.net
There is no occurence of -03 in the whole source tree of PHP, so it can't possible be something that we do. I assume it's some problem with Apple's buildtools (again). Not a bug in PHP -> bogus.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jul 28 08:01:24 2021 UTC