php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29635 undefined reference to php_startup_internal_extensions
Submitted: 2004-08-12 16:55 UTC Modified: 2004-08-28 20:25 UTC
From: afales at mac dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.8 OS: 4.10-STABLE FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: afales at mac dot com
New email:
PHP Version: OS:

 

 [2004-08-12 16:55 UTC] afales at mac dot com
Description:
------------
The configure works fine: ./configure --with-mysql=/usr/
local/mysql-4.0.20 --with-apache=/usr/local/apache_1.3.31/
build --enable-ftp --with-openssl --enable-calendar --
enable-sockets --with-pear --with-mcrypt=/usr/local --with-
prefix=/usr/local/php-4.3.8

But when I type make I get: 
gcc  -Iext/standard/ -I/usr/local/php-4.3.8/build/ext/
standard/ -DPHP_ATOM_INC -I/usr/local/php-4.3.8/build/
include -I/usr/local/php-4.3.8/build/main -I/usr/local/php-
4.3.8/build -I/usr/local/php-4.3.8/build/Zend -I/usr/local/
include -I/usr/local/mysql-4.0.20/include/mysql -I/usr/
local/php-4.3.8/build/ext/xml/expat  -I/usr/local/php-
4.3.8/build/TSRM  -g -O2  -c /usr/local/php-4.3.8/build/
ext/standard/info.c -o ext/standard/info.o  && echo > ext/
standard/info.lo
gcc  -Imain/ -I/usr/local/php-4.3.8/build/main/ -
DPHP_ATOM_INC -I/usr/local/php-4.3.8/build/include -I/usr/
local/php-4.3.8/build/main -I/usr/local/php-4.3.8/build -I/
usr/local/php-4.3.8/build/Zend -I/usr/local/include -I/usr/
local/mysql-4.0.20/include/mysql -I/usr/local/php-4.3.8/
build/ext/xml/expat  -I/usr/local/php-4.3.8/build/TSRM  -g 
-O2  -c main/internal_functions.c -o main/
internal_functions.o  && echo > main/internal_functions.lo
/bin/sh /usr/local/php-4.3.8/build/libtool --silent --
preserve-dup-deps --mode=link gcc -g -O2 -prefer-non-pic -
static  -rpath /usr/local/php-4.3.8/build/libs -rdynamic -
L/usr/local/lib -L/usr/local/mysql-4.0.20/lib/mysql  -R /
usr/local/lib -R /usr/local/mysql-4.0.20/lib/mysql ext/
openssl/openssl.lo ext/calendar/calendar.lo ext/calendar/
dow.lo ext/calendar/french.lo ext/calendar/gregor.lo ext/
calendar/jewish.lo ext/calendar/julian.lo ext/calendar/
easter.lo ext/calendar/cal_unix.lo ext/ctype/ctype.lo ext/
ftp/php_ftp.lo ext/ftp/ftp.lo ext/mcrypt/mcrypt.lo ext/
mysql/php_mysql.lo ext/overload/overload.lo ext/pcre/
pcrelib/maketables.lo ext/pcre/pcrelib/get.lo ext/pcre/
pcrelib/study.lo ext/pcre/pcrelib/pcre.lo ext/pcre/
php_pcre.lo ext/posix/posix.lo ext/session/session.lo ext/
session/mod_files.lo ext/session/mod_mm.lo ext/session/
mod_user.lo ext/sockets/sockets.lo regex/regcomp.lo regex/
regexec.lo regex/regerror.lo regex/regfree.lo ext/standard/
array.lo ext/standard/base64.lo ext/standard/
basic_functions.lo ext/standard/browscap.lo ext/standard/
crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo 
ext/standard/datetime.lo ext/standard/dir.lo ext/standard/
dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/
standard/file.lo ext/standard/filestat.lo ext/standard/
flock_compat.lo ext/standard/formatted_print.lo ext/
standard/fsock.lo ext/standard/head.lo ext/standard/html.lo 
ext/standard/image.lo ext/standard/info.lo ext/standard/
iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/
standard/mail.lo ext/standard/math.lo ext/standard/md5.lo 
ext/standard/metaphone.lo ext/standard/microtime.lo ext/
standard/pack.lo ext/standard/pageinfo.lo ext/standard/
parsedate.lo ext/standard/quot_print.lo ext/standard/
rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/
standard/string.lo ext/standard/scanf.lo ext/standard/
syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/
standard/url.lo ext/standard/url_scanner.lo ext/standard/
var.lo ext/standard/versioning.lo ext/standard/assert.lo 
ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/
standard/incomplete_class.lo ext/standard/url_scanner_ex.lo 
ext/standard/ftp_fopen_wrapper.lo ext/standard/
http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo 
ext/standard/credits.lo ext/standard/css.lo ext/standard/
var_unserializer.lo ext/standard/ftok.lo ext/standard/
aggregation.lo ext/standard/sha1.lo ext/tokenizer/
tokenizer.lo ext/xml/xml.lo ext/xml/expat/xmlparse.lo ext/
xml/expat/xmlrole.lo ext/xml/expat/xmltok.lo TSRM/TSRM.lo 
TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo 
main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/
safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/
php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo 
main/php_content_types.lo main/strlcpy.lo main/strlcat.lo 
main/mergesort.lo main/reentrancy.lo main/php_variables.lo 
main/php_ticks.lo main/streams.lo main/network.lo main/
php_open_temporary_file.lo main/php_logos.lo main/output.lo 
main/memory_streams.lo main/user_streams.lo Zend/
zend_language_parser.lo Zend/zend_language_scanner.lo Zend/
zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/
zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo 
Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/
zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo 
Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/
zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/
zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/
zend_list.lo Zend/zend_indent.lo Zend/
zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/
zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/
zend_execute.lo sapi/apache/sapi_apache.lo sapi/apache/
mod_php4.lo sapi/apache/php_apache.lo main/
internal_functions.lo -lcrypt -lcrypt -lmysqlclient -
lmcrypt -lltdl -lm -lssl -lcrypto -lcrypt -lcrypt  -o 
libphp4.la
*** Error code 1 (ignored)
gcc  -Imain/ -I/usr/local/php-4.3.8/build/main/ -
DPHP_ATOM_INC -I/usr/local/php-4.3.8/build/include -I/usr/
local/php-4.3.8/build/main -I/usr/local/php-4.3.8/build -I/
usr/local/php-4.3.8/build/Zend -I/usr/local/include -I/usr/
local/mysql-4.0.20/include/mysql -I/usr/local/php-4.3.8/
build/ext/xml/expat  -I/usr/local/php-4.3.8/build/TSRM  -g 
-O2  -c main/internal_functions_cli.c -o main/
internal_functions_cli.o  && echo > main/
internal_functions_cli.lo
/bin/sh /usr/local/php-4.3.8/build/libtool --silent --
preserve-dup-deps --mode=link gcc -export-dynamic -g -O2  -
rdynamic -L/usr/local/lib -L/usr/local/mysql-4.0.20/lib/
mysql  -R /usr/local/lib -R /usr/local/mysql-4.0.20/lib/
mysql ext/openssl/openssl.lo ext/calendar/calendar.lo ext/
calendar/dow.lo ext/calendar/french.lo ext/calendar/
gregor.lo ext/calendar/jewish.lo ext/calendar/julian.lo 
ext/calendar/easter.lo ext/calendar/cal_unix.lo ext/ctype/
ctype.lo ext/ftp/php_ftp.lo ext/ftp/ftp.lo ext/mcrypt/
mcrypt.lo ext/mysql/php_mysql.lo ext/overload/overload.lo 
ext/pcre/pcrelib/maketables.lo ext/pcre/pcrelib/get.lo ext/
pcre/pcrelib/study.lo ext/pcre/pcrelib/pcre.lo ext/pcre/
php_pcre.lo ext/posix/posix.lo ext/session/session.lo ext/
session/mod_files.lo ext/session/mod_mm.lo ext/session/
mod_user.lo ext/sockets/sockets.lo regex/regcomp.lo regex/
regexec.lo regex/regerror.lo regex/regfree.lo ext/standard/
array.lo ext/standard/base64.lo ext/standard/
basic_functions.lo ext/standard/browscap.lo ext/standard/
crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo 
ext/standard/datetime.lo ext/standard/dir.lo ext/standard/
dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/
standard/file.lo ext/standard/filestat.lo ext/standard/
flock_compat.lo ext/standard/formatted_print.lo ext/
standard/fsock.lo ext/standard/head.lo ext/standard/html.lo 
ext/standard/image.lo ext/standard/info.lo ext/standard/
iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/
standard/mail.lo ext/standard/math.lo ext/standard/md5.lo 
ext/standard/metaphone.lo ext/standard/microtime.lo ext/
standard/pack.lo ext/standard/pageinfo.lo ext/standard/
parsedate.lo ext/standard/quot_print.lo ext/standard/
rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/
standard/string.lo ext/standard/scanf.lo ext/standard/
syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/
standard/url.lo ext/standard/url_scanner.lo ext/standard/
var.lo ext/standard/versioning.lo ext/standard/assert.lo 
ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/
standard/incomplete_class.lo ext/standard/url_scanner_ex.lo 
ext/standard/ftp_fopen_wrapper.lo ext/standard/
http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo 
ext/standard/credits.lo ext/standard/css.lo ext/standard/
var_unserializer.lo ext/standard/ftok.lo ext/standard/
aggregation.lo ext/standard/sha1.lo ext/tokenizer/
tokenizer.lo ext/xml/xml.lo ext/xml/expat/xmlparse.lo ext/
xml/expat/xmlrole.lo ext/xml/expat/xmltok.lo TSRM/TSRM.lo 
TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo 
main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/
safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/
php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo 
main/php_content_types.lo main/strlcpy.lo main/strlcat.lo 
main/mergesort.lo main/reentrancy.lo main/php_variables.lo 
main/php_ticks.lo main/streams.lo main/network.lo main/
php_open_temporary_file.lo main/php_logos.lo main/output.lo 
main/memory_streams.lo main/user_streams.lo Zend/
zend_language_parser.lo Zend/zend_language_scanner.lo Zend/
zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/
zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo 
Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/
zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo 
Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/
zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/
zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/
zend_list.lo Zend/zend_indent.lo Zend/
zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/
zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/
zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo 
main/internal_functions_cli.lo -lcrypt -lcrypt -
lmysqlclient -lmcrypt -lltdl -lm -lssl -lcrypto -lcrypt -
lcrypt  -o sapi/cli/php
main/main.o: In function `php_module_startup':
/usr/local/php-4.3.8/build/main/main.c:1221: undefined 
reference to `php_startup_internal_extensions'
*** Error code 1

Stop in /usr/local/php-4.3.8/build.

I've upgraded OpenSSL -OpenSSL 0.9.7d 17 Mar 2004- on this 
machine hoping that it what the problem was...




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-28 20:25 UTC] sniper@php.net
Thank you for the useless data filling our already packed database and making the searches of real bugs even harder.

Ask support questions elsewhere (after reading the INSTALL file and the manual about HOW to install..)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 00:01:25 2020 UTC