php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29630 When compiled with --with-imap and --with-recode, PHP crashes on startup
Submitted: 2004-08-12 14:06 UTC Modified: 2004-08-12 14:19 UTC
From: boro at fixel dot org Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.3.8 OS: Slackware Linux 10.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: boro at fixel dot org
New email:
PHP Version: OS:

 

 [2004-08-12 14:06 UTC] boro at fixel dot org
Description:
------------
PHP 4.3.8 segfaults when compiled with both --with-recode and --with-imap. Leave out either one and PHP works fine. Used versions Recode 3.6 and WU-imap 2004a.



Reproduce code:
---------------
Just compile PHP with configure options --with-imap --with-recode --with-openssl, make and then try running sapi/cli/php.

Expected result:
----------------
PHP should not crash.

Actual result:
--------------
PHP crashes:

(gdb) run
Starting program: /usr/src/php-4.3.8/sapi/cli/php 

Program received signal SIGSEGV, Segmentation fault.
hash_lookup (hashtab=0x825b648, key=0xbffff470 "??\024@\\Y\030@Ȏ%\bȎ%\b????\220?") at misc.c:296
296     {
(gdb) bt
#0  hash_lookup (hashtab=0x825b648, key=0xbffff470 "??\024@\\Y\030@Ȏ%\bȎ%\b????\220?") at misc.c:296
#1  0x400943ec in find_alias (outer=0x825b4c8, name=0x4014aff1 "data", find_type=13) at names.c:273
#2  0x40096018 in register_all_modules (outer=0x825b4c8) at outer.c:457
#3  0x40096768 in recode_new_outer (auto_abort=false) at outer.c:550
#4  0x080a6ebc in zm_startup_recode (type=1, module_number=5) at /usr/src/php-4.3.8/ext/recode/recode.c:102
#5  0x0813d083 in zend_startup_module (module=0x8221c40) at /usr/src/php-4.3.8/Zend/zend_API.c:1005
#6  0x08114ba9 in php_startup_extensions (ptr=0x822b910, count=13) at /usr/src/php-4.3.8/main/main.c:1044
#7  0x0814b9d2 in php_startup_internal_extensions () at main/internal_functions_cli.c:67
#8  0x08114f5a in php_module_startup (sf=0x6, additional_modules=0x0, num_additional_modules=0)
    at /usr/src/php-4.3.8/main/main.c:1216
#9  0x0814ae65 in main (argc=1, argv=0xbffff784) at /usr/src/php-4.3.8/sapi/cli/php_cli.c:576
(gdb) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-12 14:19 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

See:
http://no2.php.net/recode

it\'s not a problem we can fix, either recode or imap needs to fix the library as they have conflicting symbols and both are not willing to change. I do recommend you to write to those two development teams.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 15:05:53 2022 UTC