php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29603 Apache crash when trying to include non-existant files
Submitted: 2004-08-10 17:55 UTC Modified: 2010-12-20 10:26 UTC
Votes:2
Avg. Score:4.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: ressourceweb at hotmail dot com Assigned: jani (profile)
Status: Closed Package: Apache related
PHP Version: 5.0.0 OS: Windows XP Home Edition
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ressourceweb at hotmail dot com
New email:
PHP Version: OS:

 

 [2004-08-10 17:55 UTC] ressourceweb at hotmail dot com
Description:
------------
Every time I tried to include into a PHP script, by accident, a file that didn't exist, Apache crashed and displayed a dialog box saying

?Apache2 caused an unhandled exception error. Do you wish to debug??

instead of logging the error in the PHP error log.

This error did not happen when I tried to include a file that existed. 

I tried to correct the problem by disabling, one by one, my php extensions and I discovered that php_pspell.dll was causing the repeated crashes.

I am using PHP 5.0.0 with Apache Web Server 2.0.50 on Windows XP Home Edition, Service Pack 1.

Extensions used by PHP
php_bz2.dll, php_cpdf.dll, php_curl.dll, php_dba.dll, php_dbx.dll, php_fdf.dll, php_gd2.dll, php_gettext.dll, php_imap.dll, php_ldap.dll, php_mbstring.dll, php_mcrypt.dll, php_mhash.dll, php_ming.dll, php_mysql.dll, php_pdf.dll, php_snmp.dll, php_sockets.dll, php_tidy.dll, php_xmlrpc.dll, php_xsl.dll, php_zip.dll, php_perl.dll, php_xmlreader.dll, php_pspell.dll, php_lzf.dll, php_mailparse.dll

Reproduce code:
---------------
<?php
include("nonexistent.inc.php");
?>

Expected result:
----------------
PHP Warning : Cannot include file nonexistent.inc.php (or something similar)

Actual result:
--------------
?Apache2 caused an unhandled exception error. Do you wish to debug??

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-21 22:57 UTC] jorton@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.0-win32-latest.zip

Please try 5.0.2 or a release snapshot, I can't reproduce this here (5.0.2 with the apache2handler on 2.0.52 on Linux, anyway).
 [2004-10-21 23:10 UTC] ressourceweb at hotmail dot com
Thanx. Tried it with PHP 5.0.2 and Apache no longer crashes.

I don't know what corrected this problem, as my configuration changed a lot since the original bugreport.

>>Previous configuration
>> I am using PHP 5.0.0 with Apache Web Server 2.0.50 on
>> Windows XP Home Edition, Service Pack 1.

Actual configuration
I am using PHP *5.0.2* with Apache Web Server *2.0.52* on Windows XP Home Edition, *Service Pack 2*.
 [2010-12-20 10:26 UTC] jani@php.net
-Package: Tidy +Package: Apache related -Assigned To: +Assigned To: jani
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 07:05:45 2022 UTC