php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29561 config.m4 path fix
Submitted: 2004-08-07 06:25 UTC Modified: 2004-08-07 07:13 UTC
From: eric at php-oop dot net Assigned:
Status: Closed Package: PHP-GTK related
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
2 + 17 = ?
Subscribe to this entry?

 
 [2004-08-07 06:25 UTC] eric at php-oop dot net
Description:
------------
When compiling PHP-GTK and using --with-php-config=/path/to/php-config the configure script fails to read the proper install prefix and could potentally cause problems later on with make. The line causing the problem is

PHP_PREFIX=`php-config --prefix`

I have included a cvs diff from the latest source in CVS that seems to cure the problem by changing php-config to $PHP_CONFIG. I havn't tested it myself, but after greping configure source the problem line was fixed.


Index: config.m4
===================================================================
RCS file: /repository/php-gtk/config.m4,v
retrieving revision 1.9
diff -u -r1.9 config.m4
--- config.m4   6 Dec 2003 20:47:10 -0000       1.9
+++ config.m4   7 Aug 2004 04:17:23 -0000
@@ -9,7 +9,7 @@
 
 if test "$PHP_PHP_GTK" != "no"; then
 
-  PHP_PREFIX=`php-config --prefix`
+  PHP_PREFIX=`$PHP_CONFIG --prefix`
   AC_MSG_CHECKING(for PHP executable in $PHP_PREFIX/bin)
   if test -x $PHP_PREFIX/bin/php; then
     PHP_VERSION=`$PHP_CONFIG --version`



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-07 07:13 UTC] andrei@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Will be in PHP-GTK 1.0.1 release.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 00:01:27 2019 UTC