php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29548 Apache2/PHP Module crashes
Submitted: 2004-08-06 15:18 UTC Modified: 2004-12-13 07:43 UTC
Votes:4
Avg. Score:4.2 ± 1.3
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: tom at ideaweb dot de Assigned:
Status: Wont fix Package: XSLT related
PHP Version: 4.3.8 OS: Debian Testing
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tom at ideaweb dot de
New email:
PHP Version: OS:

 

 [2004-08-06 15:18 UTC] tom at ideaweb dot de
Description:
------------
hi,

i have a small content management system, which 
transforms xml documents to evaluated php templates. 
with huge data the apache2.0.50 crashes with the 
following 
message in the error log:

httpd: domprovider.h:269: virtual SXP_NodeType 
DOMProviderUniversal::getNodeType(void*): Assertion `!!
(external)' failed.
[Mon Aug 02 20:15:58 2004] [notice] child pid 20982 exit 
signal Aborted (6)
httpd: domprovider.h:269: virtual SXP_NodeType 
DOMProviderUniversal::getNodeType(void*): Assertion `!!
(external)' failed.
[Mon Aug 02 20:16:08 2004] [notice] child pid 21091 exit 
signal Aborted (6)
httpd: domprovider.h:269: virtual SXP_NodeType 
DOMProviderUniversal::getNodeType(void*): Assertion `!!
(external)' failed.
[Mon Aug 02 20:23:50 2004] [notice] child pid 21440 exit 
signal Aborted (6)
httpd: domprovider.h:269: virtual SXP_NodeType 
DOMProviderUniversal::getNodeType(void*): Assertion `!!
(external)' failed.
[Mon Aug 02 20:50:11 2004] [notice] child pid 28053 exit 
signal Aborted (6)
httpd: domprovider.h:269: virtual SXP_NodeType 
DOMProviderUniversal::getNodeType(void*): Assertion `!!
(external)' failed.
[Mon Aug 02 20:52:20 2004] [notice] child pid 28197 exit 
signal Aborted (6)

if i change some content in cdata notes, the 
transformation over sabltron xsl works in some cases 
again. with small documents no problem.




Reproduce code:
---------------
sorry its to complex to post this in 20 line. if you have questions contact me.

Expected result:
----------------
no crashes at any kind programming failures...

Actual result:
--------------
root:/etc/firewall# /www/apache/current/bin/httpd -X
Aborted

the apache webserver quits only with "Aborted",the the 
same error message in the error log and without a core 
file.

???

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-07 13:49 UTC] chregu@php.net
Looks like a problem in the XSLT/Sablotron extension of PHP 4.3 (not my area ;)  )
 [2004-09-04 21:47 UTC] rasmus@php.net
Use ext/domlxml and its xslt support instead.
 [2004-09-05 17:36 UTC] tom at ideaweb dot de
it happens with sablot 1.0.1. with 0.98 there are no problems.
 [2004-09-06 00:27 UTC] rasmus@php.net
We have moved completely to libxml2 and I don't think anybody is working with Sablotron anymore.  I am sure you are right that there is a bug there, but I just don't think anybody is all that motivated to go back and try to fix it.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Jun 24 05:01:39 2018 UTC