php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29481 HSE_REQ_MAP_URL_TO_PATH_EX failed
Submitted: 2004-08-01 14:42 UTC Modified: 2004-09-26 04:05 UTC
From: steffen at land10web dot com Assigned:
Status: Not a bug Package: URL related
PHP Version: 5CVS-2004-08-01 (dev) OS: Windows XP + Sambar 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: steffen at land10web dot com
New email:
PHP Version: OS:

 

 [2004-08-01 14:42 UTC] steffen at land10web dot com
Description:
------------
Using Sambar 6.1 and I get in the ISAPI log:

With eg. the URL www.sambarserver.info/forum/viewforum.php?f=2 :

PHP5ISAPI.DLL: HSE_REQ_MAP_URL_TO_PATH_EX failed '?f=1'

All is working fine, only a lot failed enties in the log.

The response from Sambar Support is:
"I believe the URL_TO_PATH_EX is an issue on the part of PHP.  They should not be passing the ?f=2 in their lookup as that is not a valid element of the URL"

Regards,

Steffen 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-08-01 15:30 UTC] wez@php.net
?f=2 *is* a valid component of an URL.

It works on IIS, which is our only "officially supported" (and strongly discouraged) ISAPI platform.

None of us have Sambar server or the time to test it.
Volunteers are welcome to submit a patch to fix it under Sambar, but it must also not break IIS.

 [2004-08-19 00:47 UTC] tod at sambar dot com
I'm happy to add support for this, but need to know what you are expecting as a response.  Since there is no URI element to translate, do I just parrot back the ?x=y args from the Query string?

Many thanks!
Tod Sambar
 [2004-09-10 14:02 UTC] wez@php.net
Tod: please try to have it work the same way as the MS implementation, whatever that may be (still too busy to dig into it).
We'd welcome your patch!
 [2004-09-26 03:58 UTC] steffen at land10web dot com
It is fixed by Tod in the Sambar 6.1 production release (see http://www.sambarserver.info ).

PHP5 works great now with the Sambar Server.

Steffen
 [2004-09-26 04:05 UTC] wez@php.net
User reports the problem resolved in latest Sambar release.
Marking this report as Bogus since the fix did not require changes in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 10:03:34 2021 UTC