|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29402 Oracle 9i lib path issue in configure script
Submitted: 2004-07-27 04:38 UTC Modified: 2004-09-12 08:39 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: brian dot bush at alltel dot com Assigned: tony2001 (profile)
Status: Closed Package: OCI8 related
PHP Version: 5.0.0 OS: SunOS 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: brian dot bush at alltel dot com
New email:
PHP Version: OS:


 [2004-07-27 04:38 UTC] brian dot bush at alltel dot com
We were getting an error about the readline library not being found during the configure process.

We have just upgraded to Oracle 9.2.0 which has moved its 32-bit libraries to $ORACLE_HOME/lib32 from $ORACLE_HOME/lib. config.log gave more clues that this was the problem.

We fixed it by changing the $OCI8_DIR/lib and $ORACLE_DIR/lib to $OCI8/lib32 and $ORACLE_DIR/lib32 respectively in the configure script.

I think the configure script should have an option added that will specify to use 64 or 32 bit Oracle libraries.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-28 10:18 UTC]
Could you plz try this patch: 
and tell me does it work for you?
Run ./buildconf --force && ./configure after applying it.
 [2004-07-28 23:49 UTC] brian dot bush at alltel dot com
The patch works great. I was able to successfully compile with Oracle 8.1.7 and Oracle 9.2.0.

Great job. Thanks.
 [2004-07-29 10:42 UTC]
Ok, so I'll consider commiting it.
Thanks for your help.
 [2004-08-04 00:45 UTC] games at iworlds dot net
Worked for me too!  This will be a lifesaver if it can make it into a future release.
 [2004-09-12 08:39 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Mar 21 18:03:39 2023 UTC