php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2939 OCI8 apache module fails when mod_auth_oracle is used
Submitted: 1999-12-09 04:58 UTC Modified: 2006-07-17 08:07 UTC
From: iain at monitormedia dot co dot uk Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0 Beta 2 OS: Linux RedHat 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: iain at monitormedia dot co dot uk
New email:
PHP Version: OS:

 

 [1999-12-09 04:58 UTC] iain at monitormedia dot co dot uk
Apache 1.3.9 with mod_auth_oracle and php4.0b2 compiled with oci8. oci8 becomes unable to contact the database once mod_auth_oracle has authenticated a user. 

I thought this may be a bizarre problem to do with both modules accessing  the oracle shared libraries, so I tried folding the mod_auth_oracle code into mod_php4.c, but the same thing happens running this revised lib.

Does anyone have any ideas or similar experiences?

My configuration line:
--enable-sysvshm --enable-sysvsem --with-apxs=/usr/sbin/apxs --with-oci8 --with-ttf --with-gd --with-config-file-path=/etc/httpd.

I also tried upgrading to 4.0b3, but the new build does not link the oci8 libraries correctly, complaining about missing shared versions of psa, nlsrtl3 and core4 libraries.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-13 13:32 UTC] iain at monitormedia dot co dot uk
I have since got beta3 to build - it displays the same behaviour. 

I have also reproduced this on a Sun SPARC/SunOS 5.7 system.

Both the Linux and Sun systems run Oracle 8.0.5.
 [2000-07-23 02:23 UTC] zak at cvs dot php dot net
Have contacted user to see if problem still occurs with latest release of PHP.
 [2000-07-25 18:25 UTC] zak@php.net
User switched to a different oracle authentication module.  Problem disappeared after this.

I do not know if the developers will want to pursue the bug beyond this...

In any case, here is the user's message.

Iain Frerichs wrote:
" To be honest, I believed the problem to be related to mixing old-style (oracle 7) calls in the mod_auth_oracle module with the newer oci8 interface. I have since found a different oracle authentication module, by Ben Reser (http://ben.reser.org/) which works fine both on Linux and Solaris.

I have therefore abandoned Serg Oskin's module in favour of Ben's."
 [2000-08-20 03:22 UTC] sniper@php.net
Ancient. And problem solved.

--Jani
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Mar 25 03:01:25 2019 UTC