php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29388 Header Function is broken
Submitted: 2004-07-26 16:26 UTC Modified: 2004-07-26 16:37 UTC
From: arthur at petraclc dot com Assigned:
Status: Not a bug Package: *URL Functions
PHP Version: 5CVS-2004-07-26 (dev) OS: RH 2.4.20-28.8smp
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: arthur at petraclc dot com
New email:
PHP Version: OS:

 

 [2004-07-26 16:26 UTC] arthur at petraclc dot com
Description:
------------
After discovering that there was a bug with version 5.0.0 (HTTP authentication broken - discovered through working with phpMyAdmin-2.5.7.pl1) I went to the CVS snapshot version Jul 26, 2004.

The HTTP authentication now works, but the "header" function is broken.  In Version 5.0.0, the header function was working.



Expected result:
----------------
header function should have redirected to the target page.


Actual result:
--------------
"Page Not Found" error showed up instead.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-26 16:34 UTC] arthur at petraclc dot com
As an aside, phpMyAdmin 2.6.0-beta2 has corrected a problem from version 2.5.7-pl1 against PHP5.1.0-CVS where it would report a MySQL "user not found" error.

The problem was with phpMyAdmin, not PHP5 in this case.
 [2004-07-26 16:37 UTC] tony2001@php.net
Not a bug? -> bogus.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 20:03:37 2021 UTC