php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29302 Stripping of strings in front of the last umlauts
Submitted: 2004-07-21 15:33 UTC Modified: 2004-07-21 23:01 UTC
From: revolutio at gmx dot de Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 5.0.0 OS: SuSE Linux 9.1 (with Apache2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: revolutio at gmx dot de
New email:
PHP Version: OS:

 

 [2004-07-21 15:33 UTC] revolutio at gmx dot de
Description:
------------
In php5 it strips the string befor the umlauts. This script is working in php4 best. (You only see the bug, if an umlauts is in the heise news feed)

./configure --prefix=/usr/local/php --with-apxs2=/usr/local/apache2/bin/apxs --with-gd --with-mysql=/usr/local/mysql --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --with-zlib-dir=/usr/lib --with-freetype-dir=/usr/lib


Reproduce code:
---------------
http://nopaste.php-q.net/72902

Expected result:
----------------
I want to see the complete title of the news feed.

Actual result:
--------------
It stripts the string in front of the last umlauts. (Like ?/?/?)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-21 20:18 UTC] rrichards@php.net
text can be split into multiple chunks depending upon buffer size, characters encountered, etc.. which means the parser can fire off multiple events. you need to concat the text until its finished. your exmple is assuming all text returned at once so you are only using the data from the last event.
 [2004-07-21 22:14 UTC] revolutio at gmx dot de
Thx for the help. It works now with your describtion.
 [2004-07-21 23:01 UTC] derick@php.net
still not a bug -> bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 22:03:34 2021 UTC