php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29237 im french...
Submitted: 2004-07-18 04:03 UTC Modified: 2004-07-18 18:23 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: maxdc89 at hotmail dot com Assigned:
Status: Closed Package: Website problem
PHP Version: 5.0.0 OS: your website
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: maxdc89 at hotmail dot com
New email:
PHP Version: OS:

 

 [2004-07-18 04:03 UTC] maxdc89 at hotmail dot com
Description:
------------
http://fr.php.net/manual/fr/function.isset.php

Error on Exemple 1 :
if (isset($var)) {
   echo 'Cette variable existe, donc je peux l'afficher.';
}

need a \

Reproduce code:
---------------
<?php

$var = '';

// Ceci est vrai, alors le texte est affich?
if (isset($var)) {
   echo 'Cette variable existe, donc je peux l'afficher.';
}

// Dans les exemples suivants, nous utilisons var_dump() pour afficher 
// le retour de la fonction isset().

$a = 'test';
$b = 'anothertest';

var_dump(isset($a));      // TRUE
var_dump(isset($a, $b)); // TRUE

unset ($a);

var_dump(isset($a));    // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));  // FALSE

?> 

Expected result:
----------------
???

Actual result:
--------------
.....

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-18 18:23 UTC] dams@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Feb 07 06:05:51 2023 UTC