php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29224 DB Error: extension not found
Submitted: 2004-07-17 12:19 UTC Modified: 2004-09-02 13:16 UTC
Votes:6
Avg. Score:4.5 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:4 (80.0%)
From: marcschroeder at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.0.1 OS: Microsoft Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marcschroeder at hotmail dot com
New email:
PHP Version: OS:

 

 [2004-07-17 12:19 UTC] marcschroeder at hotmail dot com
Description:
------------
I had installed the windows binaries php-4.3.6-Win32.zip, and the PEAR DB package worked fine. After installing the binaries php-5.0.0-Win32.zip, I got the error "DB Error: extension not found".

Remarks: 
(1) Copying the file php_mysql.dll into the directory C:\WINDOWS\systm32 does not help.
(2) Even if it did, there would be a bug.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-17 12:33 UTC] marcschroeder at hotmail dot com
Remark (3): commenting in the line "extension=php_mysql.dll"
in php.ini does not help either
 [2004-07-30 11:29 UTC] patrick dot allaert at belgacom dot be
After the installation on WindowsXP/IIS of PHP 5.0.0 (stable) in c:\PHP\ and configuring the php.ini with:

extension_dir = "c:\PHP\ext"

I receive the following message:

"PHP Startup: Unable to load dynamic library 'c:\PHP\ext\php_EXTENSIONNAME.dll' - The specified module could not be found"

for all extensions except:

php_bz2.dll
php_cpdf.dll
php_curl.dll
php_dba.dll
php_dbase.dll
php_dbx.dll
php_filepro.dll
php_gd2.dll
php_gettext.dll
php_imap.dll
php_ldap.dll
php_mbstring.dll
php_mime_magic.dll
php_ming.dll
php_mysqli.dll
php_openssl.dll
php_oracle.dll
php_pgsql.dll
php_shmop.dll
php_snmp.dll
php_sockets.dll
php_tidy.dll
php_xmlrpc.dll
php_xsl.dll

All the other extensions result in the error above (of course, some of them cannot be loaded because of 3rd-parties dll missing like with oci8 but what about php_mysql.dll, php_mysqli.dll, ...)
 [2004-08-02 00:36 UTC] tipsen at imada dot sdu dot dk
I solved the problem by copying the file "libmysql.dll" from the php5 root to the win/system32 library - I have no idea why this works but stumpled upon the suggestion on a website!

Regards, Tommy Ipsen
 [2004-08-02 11:24 UTC] edink@php.net
Either add c:\php to your system path, or copy all dlls from that folder to system32.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 07:01:27 2024 UTC