|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29147 Compile Error in mnoGoSearch functions)
Submitted: 2004-07-14 15:28 UTC Modified: 2004-07-18 13:19 UTC
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:0 (0.0%)
From: sebastian at nohn dot net Assigned:
Status: Closed Package: Compile Failure
PHP Version: 5.0.0 OS: Linux 2.4 (Debian Woody)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
1 + 1 = ?
Subscribe to this entry?

 [2004-07-14 15:28 UTC] sebastian at nohn dot net
PHP does'nt compile

Reproduce code:
./configure \
   --prefix=/opt/php \
   --sysconfdir=/etc/opt/php \
   --localstatedir=/var/opt/php \
   --with-apxs2=/opt/apache/sbin/apxs \
   --with-mysql=/usr \
   --with-pgsql=/usr \
   --with-zlib=yes \
   --with-xml \
   --enable-inline-optimization \
   --enable-sockets \
   --enable-ftp \
   --enable-wddx \
   --with-mnogosearch=/opt/mnogosearch \
   --with-gd \
   --with-freetype-dir=/usr \
   --with-gettext \

Expected result:
Everything works fine

Actual result:
/bin/sh /root/install_temp/php-5.0.0/libtool --silent --preserve-dup-deps --mode=link /root/install_temp/php-5.0.0/meta_ccld -export-dynamic -g -O2 -pthread -DZTS  -L/opt/libxml2/lib -L/usr/lib/mysql -L/opt/mnogosearch/lib -L/usr/lib/postgresql/lib  -R /opt/libxml2/lib -R /usr/lib/mysql -R /opt/mnogosearch/lib -R /usr/lib/postgresql/lib ext/libxml/libxml.lo ext/zlib/zlib.lo ext/zlib/zlib_fopen_wrapper.lo ext/ctyp [...] d_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_ts_hash.lo Zend/zend_stream.lo Zend/zend_iterators.lo Zend/zend_interfaces.lo Zend/zend_exceptions.lo Zend/zend_objects.lo Zend/zend_object_handlers.lo Zend/zend_objects_API.lo Zend/zend_mm.lo Zend/zend_default_classes.lo Zend/zend_reflection_api.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -lcrypt -lcrypt -lpq -lmysqlclient -lfreetype -lpng -lz -lz -lresolv -lm -ldl -lnsl -lxml2 -lz -lm -lxml2 -lz -lm -lmysqlclient -lm -lz -ludmsearch -lxml2 -lz -lm -lcrypt -lxml2 -lz -lm -lcrypt  -o sapi/cli/php
/opt/mnogosearch/lib/libudmsearch.a(parser.o): In function `parse_file':
/root/install_temp/mnogosearch-3.1.21/src/parser.c:258: the use of `tmpnam' is dangerous, better use `mkstemp'
ext/mnogosearch/php_mnogo.lo: In function `MyRemoveHiLightDup':
/root/install_temp/php-5.0.0/ext/mnogosearch/php_mnogo.c:433: undefined reference to `UdmMalloc'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-14 21:30 UTC] php at arwin dot net
I had the same error when trying to include support for mnogosearch.  The exact same configuration worked fine in php 5.0.0RC3.
 [2004-07-15 19:57 UTC] Bjorn dot Wiberg at its dot uu dot se
I experience the same error on IBM AIX ML3 with PHP 5.0.0 (release) and mnoGoSearch 3.1.21 installed in the standard location /usr/local/mnogosearch.

PHP has been configured with (excerpt from config.nice):

CPPFLAGS='-I/usr/local/include' \
LDFLAGS='-L/lib -L/opt/freeware/lib -L/usr/local/lib' \
CC='/usr/local/bin/gcc' \
'./configure' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-dba' \
'--enable-exif' \
'--enable-embedded-mysqli' \
'--enable-debug' \
'--enable-filepro' \
'--enable-gd-jis-conv' \
'--enable-gd-native-ttf' \
'--enable-mbstring' \
'--enable-memory-limit' \
'--enable-versioning' \
'--enable-zend-multibyte' \
'--prefix=/apache/php' \
'--with-apxs2=/apache/bin/apxs' \
'--with-apxs2filter=/apache/bin/apxs' \
'--with-freetype-dir' \
'--with-gd' \
'--with-gdbm' \
'--with-gettext' \
'--with-inifile' \
'--with-jpeg-dir' \
'--with-ldap' \
'--with-libxml-dir' \
'--with-mime-magic' \
'--with-mnogosearch' \
'--with-mysql=/usr/local/mysql' \
'--with-openssl=/opt/freeware' \
'--with-png-dir' \
'--with-tiff-dir' \
'--with-ttf' \
'--with-xpm-dir' \
'--with-zlib' \

The error message I get is:

s_API.lo Zend/zend_mm.lo Zend/zend_default_classes.lo Zend/zend_reflection_api.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -o sapi/cli/php  -L/opt/freeware/lib -L/usr/X11R6/lib -L/usr/local/lib -L/usr/local/mysql/lib -L/usr/local/mnogosearch/lib -L/usr/local/mysql/lib/mysql -lz -lm -lldap -lssl -lcrypto -ls -llber -lintl -liconv -lfreetype -lz -lX11 -lXpm -lpng -lz -ljpeg -lgdbm -lz -lssl -lcrypto -lm -lz -liconv -lm -lz -liconv -lm -lz -liconv -lm -lz -liconv -lm -lmysqlclient -lz -lcrypt -lnsl_r -lm -lm -lz -lcrypto -lssl /usr/local/mnogosearch/lib/libudmsearch.a -lmysqlclient -lm -lz -lcrypto -lssl -lz -liconv -lm -lz -liconv -lm -lxml2 -lpthread -lz -liconv -lm -lz -liconv -lm -Wl,-bnolibpath -Wl,-blibpath:/usr/local/lib:/opt/freeware/lib:/usr/local/mysql/lib/mysql:/usr/X11R6/lib:/usr/local/mysql/lib:/usr/local/mnogosearch/lib:/usr/lib:/lib
ld: 0711-317 ERROR: Undefined symbol: .UdmMalloc
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
collect2: ld returned 8 exit status
make: The error code from the last command is 1.

 [2004-07-16 08:28 UTC]
Could you please try the patch below?
 [2004-07-16 10:31 UTC] sebastian at nohn dot net
This patch seems to fix the problem. PHP5 compiles and the mnoGoSearch extensions works fine.

Thanks a lot!
 [2004-07-18 12:33 UTC]
Thank you.
I will check your patch and commit to php cvs soon.
 [2004-07-18 13:19 UTC]
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
Thank you for the report, and for helping us make PHP better.

I committed this patch into CVS.
Thank you.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 17:03:52 2021 UTC