php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2913 Missing function
Submitted: 1999-12-04 09:01 UTC Modified: 2000-01-07 01:37 UTC
From: fiorletta at mclink dot it Assigned:
Status: Closed Package: Other
PHP Version: 4B3 OS: Linux RedHat6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fiorletta at mclink dot it
New email:
PHP Version: OS:

 

 [1999-12-04 09:01 UTC] fiorletta at mclink dot it
When i try to compile php4B3 receive the following errors :

main.c: In function `php_module_startup':
main.c:864: `block_alarms' undeclared (first use in this function)
main.c:864: (Each undeclared identifier is reported only once
main.c:864: for each function it appears in.)
main.c:865: `unblock_alarms' undeclared (first use in this function)
main.c: In function `zend_hash_environment':
main.c:1024: warning: initialization makes pointer from integer without a cast
make[2]: *** [main.lo] Error 1
make[2]: Leaving directory `/home/marco/php-4.0b3'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/marco/php-4.0b3'
make: *** [all-recursive-am] Error 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-16 23:02 UTC] evan at cvs dot php dot net
Please see if this happens with PHP4 CVS and report back.
 [2000-01-07 01:37 UTC] evan at cvs dot php dot net
Unable to reproduce and poster not responding.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 15:05:53 2022 UTC