php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29117 Php and java as CGI : Premature End of script headers...
Submitted: 2004-07-13 15:28 UTC Modified: 2004-07-14 09:42 UTC
From: SouLPower at LaPoste dot fr Assigned:
Status: Not a bug Package: Java related
PHP Version: 4.3.7 OS: Windows 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: SouLPower at LaPoste dot fr
New email:
PHP Version: OS:

 

 [2004-07-13 15:28 UTC] SouLPower at LaPoste dot fr
Description:
------------
I got a big problem with java and php...

I use php as CGI because it's the only way for my javabeans to work...

I'm working on a migration from ASP to PHP pages for a firm but the ASP pages used some activeX, and now the firm wants to use javabeans with PHP...

But this javabeans don't work correctly with php :

in fact, when i load the javabeans (ie : $MaClasse = New Java("MaClass");) it works ONLY if i just load 1 classe, but i need to load 3...

So, when i use only 1 javabeans, the page comes correctly, but with 2 or more, i got this error in error.log of apache : "Premature End Of Script Headers : e:/php/php.exe"

Apache (v1.3.31) is setup correctly, and PHP too.

I use JDK (J2EE 1.4), but the bug is always there...

I don't understand why it works with 1 and not with 2 or more... 

If someone could help me please :)

Thank you very much.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-13 15:32 UTC] SouLPower at LaPoste dot fr
I got a big problem with java and php...

I use php as CGI because it's the only way for my javabeans to work...

I'm working on a migration from ASP to PHP pages for a firm but the ASP
pages used some activeX, and now the firm wants to use javabeans with
PHP...

But this javabeans don't work correctly with php :

in fact, when i load the javabeans (ie : $MaClasse = New
Java("MaClass");) it works ONLY if i just load 1 classe, but i need to
load 3...

So, when i use only 1 javabeans, the page comes correctly, but with 2 or
more, i got this error in error.log of apache : "Premature End Of Script
Headers : e:/php/php.exe"

Apache (v1.3.31) is setup correctly, and PHP too.

I use JDK (J2EE 1.4), but the bug is always there...

I don't understand why it works with 1 and not with 2 or more... 

If someone could help me please :)

Thank you very much.
 [2004-07-14 09:42 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2004-07-15 15:05 UTC] soulpower at laposte dot fr
i'm not sure it's not php...

There's many problems with the java support (i know, this support is experimental) and i must be a php problem because php.exe hangs... And it hangs only when i use 2 or more javabeans, with one, it works great (i tried all three javabeans separatly and they work fine...). I tried to configure PHP in module mode, it doesn't work, in CGI mode, it hangs...
So what is the problem ?

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 16:03:35 2021 UTC