php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29102 createimagefromstring
Submitted: 2004-07-12 03:34 UTC Modified: 2004-07-16 01:29 UTC
From: damien dot racca at free dot fr Assigned:
Status: Closed Package: GD related
PHP Version: 4.3.6 OS: XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: damien dot racca at free dot fr
New email:
PHP Version: OS:

 

 [2004-07-12 03:34 UTC] damien dot racca at free dot fr
Description:
------------
Fixed bug #21518 (imagecreatefromstring() crashed with invalid image files). (Ilia)

That seemed to be solved in earlier version that my 4.3.4 but I have still the problem. I can't update because of a free provider (free.fr) but in new versions, this bug has not be solved.

Some JPEG files (I don't know why sme can't be used !) stop the script execution.
Very ennoying because I wanted to use this finction to make thumbnails from images stored in a mysql table.

Reproduce code:
---------------
$a=createimagefromstring($myrow[0]) with $myrow[0] being a JPEG image stored in a mysql table (this JPEG can be displayed if createimagefromstring is not used !).

Expected result:
----------------
The scipt has to continue, not stopping !

Actual result:
--------------
Script stop when createimagefromstring is used.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-14 14:04 UTC] sniper@php.net
Please put the image online somewhere for us to be able to download and test ourselves.

 [2004-07-14 15:45 UTC] damien dot racca at free dot fr
here one of the image that make the script stopped at the imagecreatefromstring function

http://damien.racca.free.fr/hv0.jpg

and the phpinfo of the provider :
http://damien.racca.free.fr/hv0.jpg

If somebody could make a test...

For now I used imagecreatefromJPEG but I have to create a temp file to store the image that is in the variable after having extrected it from the MYSQL database. Not the best solution I think. But it's OK with all images (even this one that make the imagecreatefromstring failed).
 [2004-07-16 01:29 UTC] iliaa@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Works fine with latest CVS. 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 11:05:45 2022 UTC