php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29081 Segmentation Fault when using Interface
Submitted: 2004-07-09 23:15 UTC Modified: 2004-07-09 23:17 UTC
From: jason at ionzoft dot com Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.0.0RC3 OS: Redhat ES 3.0 (Intel)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jason at ionzoft dot com
New email:
PHP Version: OS:

 

 [2004-07-09 23:15 UTC] jason at ionzoft dot com
Description:
------------
Hello,

I discovered this problem tonight while working on a new PHP 5 class that uses an interface.  The code example came from http://www.zend.com/php5/articles/engine2-php5-changes.php#Heading5


<?php
   interface Throwable {
      public function getMessage();
   }

   class MyException implements Throwable {
      public function getMessage() {
          echo "Hello\n";
      }
   }

   $x = new MyException;
   $x->getMessage();
?>


------------------


On this server, I get a Segmentation Fault:

[ionzoft@lithium dev]$ php -v
PHP 5.0.0RC3 (cli) (built: Jun 24 2004 17:35:13)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC3, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.0.2, Copyright (c) 2003-2004, by Zend Technologies
    with Zend Optimizer v2.5.2, Copyright (c) 1998-2004, by Zend Technologies
    with Zend Debugger v3.5.0, Copyright (c) 1999-2004, by Zend Technologies


[ionzoft@lithium dev]$ php -f Interface.php
Segmentation fault

------------------

On this server, It works fine:

[izsp@boron Jason]$ php -v
PHP 5.0.0RC3 (cli) (built: Jun 14 2004 14:04:10)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC3, Copyright (c) 1998-2004 Zend Technologies


[izsp@boron Jason]$ php -f Interface.php
Hello

------------------

Could it be a problem with the Debugger?

Thanks,
Jason Garber


-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reproduce code:
---------------
<?php
   interface Throwable {
      public function getMessage();
   }

   class MyException implements Throwable {
      public function getMessage() {
          echo "Hello\n";
      }
   }

   $x = new MyException;
   $x->getMessage();
?>


Expected result:
----------------
Should print "Hello\n"

Actual result:
--------------
"Segmentation Fault"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-09 23:17 UTC] jason at ionzoft dot com
This is a duplicate of 29080.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 19:01:28 2020 UTC