php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29071 CLI returns an extra carriage return after exits.
Submitted: 2004-07-09 07:13 UTC Modified: 2004-07-09 09:13 UTC
From: nathan at nightsys dot net Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.0.0RC3 OS: Linux 2.4.26 (Gentoo)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nathan at nightsys dot net
New email:
PHP Version: OS:

 

 [2004-07-09 07:13 UTC] nathan at nightsys dot net
Description:
------------
CLI executable returns an extra carriage return after exit, example below.

Linux nathan1 2.4.26-gentoo-r4 #1 SMP Fri Jul 9 12:42:20 EST 2004 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz GenuineIntel GNU/Linux

Dont know if the kernel upgrade (from 2.4.25) could have affected this.

Reproduce code:
---------------
/usr/local/php/bin/php -v

Expected result:
----------------
nathan@nathan1 nathan $ /usr/local/php/bin/php -v
PHP 5.0.0RC3 (cli) (built: Jul  1 2004 14:52:38)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC3, Copyright (c) 1998-2004 Zend Technologies
nathan@nathan1 nathan $


Actual result:
--------------
nathan@nathan1 nathan $ /usr/local/php/bin/php -v
PHP 5.0.0RC3 (cli) (built: Jul  1 2004 14:52:38)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC3, Copyright (c) 1998-2004 Zend Technologies
nathan@nathan1 nathan $
nathan@nathan1 nathan $


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-09 09:13 UTC] derick@php.net
It's definiteley not caused by PHP, because if PHP would have outputted an extra new line it would have looked like this:

nathan@nathan1 nathan $ /usr/local/php/bin/php -v
PHP 5.0.0RC3 (cli) (built: Jul  1 2004 14:52:38)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC3, Copyright (c) 1998-2004 Zend Technologies

nathan@nathan1 nathan $
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 07:06:08 2022 UTC