php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2903 fails to compile ifx.ec, report a syntax-error
Submitted: 1999-12-03 09:56 UTC Modified: 2005-03-30 09:01 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: baard dot kregnes at postbanken dot no Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 3.0.12 OS: AIX 4.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: baard dot kregnes at postbanken dot no
New email:
PHP Version: OS:

 

 [1999-12-03 09:56 UTC] baard dot kregnes at postbanken dot no
./configure --with-informix --with-apache=../apache_1.3.9

Environment: 
informix: 
INFORMIX-ESQL Version 7.24.UC7   

platform:
AIX 4.3

compiler:
IBM 3.6.6 

Apache 1.3.9

php-3.0.12


But when I try to do make in the php directory this happens:

       cc -g -I/opt/informix/incl/esql -D__H_LOCALEDEF   -I. -I.   -I../apache_1.3.9/src/include -I../apache_1.3.9/src/os/unix               -I/opt/informix/incl/esql      -c functions/ifx.c -o functions/ifx.o
"functions/ifx.ec", line 1998.10: 1506-277 (S) Syntax error: possible missing ';' or ','?
"functions/ifx.ec", line 2001.7: 1506-045 (S) Undeclared identifier short_data.
"functions/ifx.ec", line 2044.73: 1506-045 (S) Undeclared identifier type.
"functions/ifx.ec", line 2045.13: 1506-045 (S) Undeclared identifier fetch_pos.
"functions/ifx.ec", line 2046.13: 1506-045 (S) Undeclared identifier fetch_row.
"functions/ifx.ec", line 2067.5: 1506-045 (S) Undeclared identifier nullstr.
"functions/ifx.ec", line 2149.5: 1506-045 (S) Undeclared identifier num_fields.
"functions/ifx.ec", line 2151.5: 1506-045 (S) Undeclared identifier locind.
"functions/ifx.ec", line 2165.9: 1506-045 (S) Undeclared identifier p.
"functions/ifx.ec", line 2178.15: 1506-045 (S) Undeclared identifier bid_b.
"functions/ifx.ec", line 2179.15: 1506-045 (S) Undeclared identifier bid.
"functions/ifx.ec", line 2200.17: 1506-045 (S) Undeclared identifier long_data.
"functions/ifx.ec", line 2201.25: 1506-045 (S) Undeclared identifier string_data.
"functions/ifx.ec", line 2214.26: 1506-045 (S) Undeclared identifier dec_data.
"functions/ifx.ec", line 2222.26: 1506-045 (S) Undeclared identifier float_data.
"functions/ifx.ec", line 2221.17: 1506-045 (S) Undeclared identifier double_data.
"functions/ifx.ec", line 2237.35: 1506-045 (S) Undeclared identifier dt_data.
"functions/ifx.ec", line 2242.35: 1506-045 (S) Undeclared identifier intvl_data.
"functions/ifx.ec", line 2301.17: 1506-045 (S) Undeclared identifier locator_b.
"functions/ifx.ec", line 2315.20: 1506-045 (S) Undeclared identifier blobfilename.
"functions/ifx.ec", line 2391.10: 1506-277 (S) Syntax error: possible missing ';' or ','?
"functions/ifx.ec", line 2394.7: 1506-045 (S) Undeclared identifier short_data.
"functions/ifx.ec", line 2395.7: 1506-045 (S) Undeclared identifier float_data.
"functions/ifx.ec", line 2396.8: 1506-045 (S) Undeclared identifier double_data.
"functions/ifx.ec", line 2430.13: 1506-045 (S) Undeclared identifier table_options.
"functions/ifx.ec", line 2446.65: 1506-045 (S) Undeclared identifier type.
"functions/ifx.ec", line 2487.13: 1506-045 (S) Undeclared identifier moredata.
"functions/ifx.ec", line 2498.5: 1506-045 (S) Undeclared identifier num_fields.
"functions/ifx.ec", line 2499.5: 1506-045 (S) Undeclared identifier nullstr.
"functions/ifx.ec", line 2518.9: 1506-045 (S) Undeclared identifier p.
"functions/ifx.ec", line 2532.9: 1506-045 (S) Undeclared identifier locind.
"functions/ifx.ec", line 2556.21: 1506-045 (S) Undeclared identifier long_data.
"functions/ifx.ec", line 2557.29: 1506-045 (S) Undeclared identifier string_data.
"functions/ifx.ec", line 2570.26: 1506-045 (S) Undeclared identifier dec_data.
"functions/ifx.ec", line 2593.35: 1506-045 (S) Undeclared identifier dt_data.
"functions/ifx.ec", line 2598.35: 1506-045 (S) Undeclared identifier intvl_data.
"functions/ifx.ec", line 2645.21: 1506-045 (S) Undeclared identifier bid_b.
"functions/ifx.ec", line 2648.21: 1506-045 (S) Undeclared identifier locator_b.
"functions/ifx.ec", line 2659.59: 1506-045 (S) Undeclared identifier content.
"functions/ifx.ec", line 2659.21: 1506-045 (S) Undeclared identifier lg.
"functions/ifx.ec", line 2665.25: 1506-045 (S) Undeclared identifier copy_content.
make: 1254-004 The error code from the last command is 1.


I've tried to compile the same version of php/apache on another (older ) AIX 
which also had a IBM compiler.. with the same result..

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-03 13:03 UTC] danny at cvs dot php dot net
It looks like configures has detected an IUS 9.x Informix version and has 
set the -EDHAVE_IFX_US esql/c preprocessor option accordingly, while your
esqlc 7.x preprocessor did not process the IUS 9.x constructs, resulting
in the syntax errors at the first IUS 9 datatypes (int8 and lvarchar).

It is possibly the output of "esql -V" on AIX that is misintertpreted by
configure. You can verify this by looking at the lines in configure that
decode the esql -V output to decide between IDS/ODS 7.x and IUS 9.x.

You might have to tweak these lines a bit if they are indeed the cause.

You can check the Makefile for the presence of -EDHAVE_IFX_US.
It shouldn't be there for ODS 7.2.

Danny
---


 [1999-12-06 08:49 UTC] baard dot kregnes at postbanken dot no
Snipped from the Makefile:
functions/ifx.c: functions/ifx.ec
        (esql -e -EUHAVE_IFX_IUS functions/ifx.ec; mv ifx.c functions)

After further 'invistigations' I found that these varibles causes the error:

intrvl_t intvl_data =  {0};
dtime_t dt_data =  {0};
dec_t dec_data =  {0};

Theses variables are defined in <../esql/datetime.h>, and
this datetime.h are included in 'sqlhdr.h'.

If I stick #include <datetime.h> in ifx.c (yes .c), it compiles.

( I'm not sure if this is a part of the same problem ?)

And the story goes on .. now it fails with:

        cc  -DAIX=43 -U__STR__ -DAIX_BIND_PROCESSOR -qnogenpcomp -qnousepcomp -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite `./apaci` -lm    -o httpd buildmark.o modules.o  modules/php3/libphp3.a  modules/standard/libstandard.a  main/libmain.a  ./os/unix/libos.a  ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a  -Lmodules/php3 -L../modules/php3 -L../../modules/php3 -lmodphp3                   -L/opt/informix/lib -L/opt/informix/lib/esql -lixsqlshr -lixasfshr -lixgenshr -lixosshr -lixglsshr -ltli -lc -lmsaa -lbsd /opt/informix/lib/esql/checkapi.o -lixglx    -lm -ldl -lnsl   
ld: 0711-317 ERROR: Undefined symbol: .ldopen
ld: 0711-317 ERROR: Undefined symbol: .ldclose
ld: 0711-317 ERROR: Undefined symbol: .ldnshread
ld: 0711-317 ERROR: Undefined symbol: .alloca
ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.
make: 1254-004 The error code from the last command is 8.



 [2005-03-30 09:01 UTC] sniper@php.net
We are sorry, but we can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Of course PHP 4 will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC