php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28915 php.exe - Application Error
Submitted: 2004-06-25 04:19 UTC Modified: 2004-07-04 01:00 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:3 (60.0%)
From: spam at pasoft dot org Assigned:
Status: No Feedback Package: Unknown/Other Function
PHP Version: Irrelevant OS: Windows/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: spam at pasoft dot org
New email:
PHP Version: OS:

 

 [2004-06-25 04:19 UTC] spam at pasoft dot org
Description:
------------
 get the
php.exe Application Error, but in my case the error is completely
random.  It will happen on one page of my project one day, and a totally
different page the next, which makes it nearly impossible to track down
and to replicate easily.
An interesting thing about this error is that it occurs in both windows
and linux versions of PHP with absolutley no extensions installed, and
is present in all versions of PHP I've trade to date.

The error reads as fallows on my windows machine:
php.exe - Application Error
The instruction at "0x100bec17" referenced memory at "0x6526176".  The
memory could not be "written".

Click on OK to terminate the program
Click on CANCEL to debug the program

On my linux machine, I just get a blank page when the error occurs (no
real error message)

I'm unsure of what to do to help you guys find the problem, this project
is a fairly large and depending on the bugs mood, it could occur
anywhere.

I'm sure its not a configuration problem.

My project makes use of:
Object Oriented Design
Sessions
MySQL
Expat (XML)
File I/O

It all started after I rewrote my XML parser, so I've enclosed the link to it, for inspection.

I would greatly appreciate some instruction that would better help you
track down this problem.

Its been driving me nuts for over a year, and any help you could provide
would help me sleep better at night

Thanks
-Sarev0k

Reproduce code:
---------------
http://www.pasoft.org/temp/parser.txt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-25 04:25 UTC] spam at pasoft dot org
I get a php.exe Application Error, but unlike other cases, I get the error at
random.  It will happen on one page of my project one day, and a
totally
different page the next, which makes it nearly impossible to track down
and to replicate easily.
An interesting thing about this error is that it occurs in both windows
and linux versions of PHP with absolutley no extensions installed, and
is present in all versions of PHP I've trade to date.

The error reads as fallows on my windows machine:
php.exe - Application Error
The instruction at "0x100bec17" referenced memory at "0x6526176".  The
memory could not be "written".

Click on OK to terminate the program
Click on CANCEL to debug the program

On my linux machine, I just get a blank page when the error occurs (no
real error message)

I'm unsure of what to do to help you guys find the problem, this
project
is a fairly large and depending on the bugs mood, it could occur
anywhere.

I'm sure its not a configuration problem.

My project makes use of:
Object Oriented Design
Sessions
MySQL
Expat (XML)
File I/O

It all started after I rewrote my XML parser, so I've enclosed the link
to it, for inspection.

I would greatly appreciate some instruction that would better help you
track down this problem.

Its been driving me nuts for over a year, and any help you could
provide
would help me sleep better at night

Thanks
-Sarev0k

Reproduce code:
---------------
http://www.pasoft.org/temp/parser.txt
 [2004-06-25 10:42 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2004-07-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-05-06 00:30 UTC] ben at remoteinformation dot com dot au
Hello, I have just started receiving this bug, on php 4.4.3-
dev and using Mapserver 4.8.3 (php_mapscript).

It is on a WinXPSP2 machine, using Apache 2.0.55 (win32)


As described below, it is sporadic (one map draws fine, the 
next one also renders properly, but the php.exe message 
appears and the system hangs until I click OK. I don't get 
any debug message, and although I followed the instructions 
to backtrace, I couldn't get them to work on the windows 
machine - is there any other place I could look.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 08:03:34 2021 UTC