php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28896 Cannot run apache's php module when php is compiled with oracle support
Submitted: 2004-06-23 18:34 UTC Modified: 2008-09-17 17:57 UTC
From: dcimafonte at yahoo dot it Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.7 OS: Compaq Tru64 5.1A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dcimafonte at yahoo dot it
New email:
PHP Version: OS:

 

 [2004-06-23 18:34 UTC] dcimafonte at yahoo dot it
Description:
------------
OS: Compaq Tru64 Unix 5.1A
WebServer: Apache 2.0

Hello,
I compiled php 4.3.7 with Oracle support, and installed it successfully, but when I run Apache 2.0 it gives me the following error message (that won't appear when I compile without oracle support):

Cannot load /common/apache/modules/libphp4.so into server: dlopen: libpthread.so: symbol "pthread_setcancelstate" unresolved

Can you guess why?

Reproduce code:
---------------
./configure --prefix=/user/dw/dwcvs/local --with-apxs2=/common/apache/bin/apxs --with-oci8
make
make install
cd /common/apache/bin
apachectl start


Expected result:
----------------
apache running

Actual result:
--------------
apache won't start.
In error_log this message appears:
Cannot load /common/apache/modules/libphp4.so into server: dlopen: libpthread.so: symbol "pthread_setcancelstate" unresolved


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-06 01:20 UTC] sniper@php.net
It somehow can't find the pthread library (or is linking with it when it shouldn't?) Not PHP bug.

 [2008-09-17 17:57 UTC] dcimafonte at yahoo dot it
could you please remove completely this submission, since it's generating spam to my main email address?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Mar 02 01:01:28 2024 UTC