|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28736 Uncaught exception 'com_exception'
Submitted: 2004-06-10 23:19 UTC Modified: 2004-09-19 00:28 UTC
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: andy at advancethermal dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 5CVS-2004-06-10 (dev) OS: WindowsXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
48 + 49 = ?
Subscribe to this entry?

 [2004-06-10 23:19 UTC] andy at advancethermal dot com
COM handling in php5-win32-200406101030 is failing where it works without error in 4.3.7.  For CrystalRunTime.Application, it is crashing with the following commands:

$creport->DiscardSavedData;  (in example below)

Reproduce code:
$crapp = new COM("CrystalRunTime.Application");
$creport = $crapp->OpenReport("c:\\myweb\\reports\\myreport.rpt", 1);

Expected result:
(no failure expected)

Actual result:
Fatal error: Uncaught exception 'com_exception' with message 'Error Member not found. ' in C:\myweb\htdocs\printlib.php:3 Stack trace: #0 C:\myweb\htdocs\faxcoverpage.php(26): PrintReport('myreport.rpt', '0', 'myreport', '', '', 'portrait', '1', Array) #1 {main} thrown in C:\myweb\htdocs\printlib.php on line 3


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-15 14:28 UTC] bhobbs at itos dot uga dot edu
I have also had this issue.

Win2K Server
Apache 2.0.49
PHP 5.0.0 RC3

$oMapDoc = new COM("Autodesk.MapWindowFile") or die("Unable to instantiate a MapWindowFile object");

($bDATValidate) ? $oMapDoc->ValidateMwx = true : $oMapDoc->ValidateMwx = false;

($bDATCompress) ? $oMapDoc->CompressMlf = true : $oMapDoc->CompressMlf = false;


($sPermMWFFilenam = tempnam( $sOutputdir, "mlf_" )) ? true : die("Unable to generate an output file name");

unlink($sPermMWFFilenam);	//It drops the temp file in place whether you use it or not....

$sPermMWFFilenam = str_replace(".tmp", ".mlf", $sPermMWFFilenam);
					//print($sPermMWFFilenam . " & " . $sGroupname . " & " . $sLayername);
					$oMapDoc->WriteToMlf($sPermMWFFilenam, $sGroupname, $sLayername);  // <------This is the line that fails....

I'm not "me tooing" (I hope).  The COM object in question is the Autodesk MapGuide Dynamic Authoring Toolkit.  The call to instantiate, set a couple of properties and read a file work fine, but the call to create a new file (the WriteToMlf() call) fails with com_exception, source: unknown description: unknown.  Catching the exception yeilds zero usable information.  I tried casting the input values as VT_BSTR, VT_UNKNOWN and VT_VARIANT, but nothing worked.  It should be noted that there is a similar method called WriteToMwf() that takes a single argument, and it works fine.

While I'm at it, there's a method called WriteToMwfStream() that returns a binary array, but I can't get to it.

Let me know and I'll see if I can dig up the idf for this thing.

 [2004-07-29 05:42 UTC]
bhobbs at itos dot uga dot edu:
Please open a separate report for your issue; if you can, please determine the IDL for that COM object.
(this might help:

andy at advancethermal dot com:
$creport->DiscardSavedData(); // method calls have () in PHP

Marking this report as bogus since it contains no usable information about a PHP bug.
 [2004-09-19 00:28 UTC]
as previously stated, this is a bogus report.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Mon Mar 20 20:03:44 2023 UTC