php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2867 Fails to build when no libbind.so
Submitted: 1999-11-30 10:56 UTC Modified: 1999-12-03 10:31 UTC
From: evb at kerridge dot com Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.0 Beta 3 OS: RH 5.1 (Mandrake), egcs 1.1.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: evb at kerridge dot com
New email:
PHP Version: OS:

 

 [1999-11-30 10:56 UTC] evb at kerridge dot com
make fails on my machine with
"Warning, this library needs some functionality provided by -lbind ....But I can only do this if you have a shared version of the library, which you do not appear to have"

My configure line was:
 ./configure  --with-java=/var/jdk117_v1a --with-mysql --with-apache=../apache_1.3.9 --enable-track-vars

I think that most systems will only have libbind.a and NOT libbind.so, since there is NO option to build a .so in the bind installation (not that I am aware of - please tell me if I am wrong)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-12-01 11:28 UTC] sas at cvs dot php dot net
You can ignore this kind of warnings.
 [1999-12-01 13:10 UTC] evb at kerridge dot com
The problem is that it fails to build libs/libphp4.a.

When you do a "make install" cp then complains that
libphp4.a is missing
When you then try to build Apache, this causes the build to fail
 [1999-12-02 03:33 UTC] evb at kerridge dot com
The problem is that it fails to build libs/libphp4.a.

When you do a "make install" cp then complains that
libphp4.a is missing
When you then try to build Apache, this causes the build to fail
 [1999-12-02 04:06 UTC] evb at kerridge dot com
The problem is that it fails to build libs/libphp4.a.

When you do a "make install" cp then complains that
libphp4.a is missing
When you then try to build Apache, this causes the build to fail
 [1999-12-02 04:22 UTC] evb at kerridge dot com
I guess it should be a separate bug... but I'll put it here anway
It looks like the bugs database has a bug....
I replied to a mail from Sascha Schumann that had a CC to the
bugs database, but instead of entering the contents of my mail,
it has re-entered the contents of an earlier entry for the same
bug in the bugs database... 
 [1999-12-03 10:31 UTC] sas at cvs dot php dot net
Fixed in CVS. The Java extension did  something wrong which breaks the build when used with a static SAPI target.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC