php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28667 strange max execution time msg
Submitted: 2004-06-07 11:59 UTC Modified: 2004-06-07 18:23 UTC
From: mister dot v at laposte dot net Assigned:
Status: Closed Package: Output Control
PHP Version: 4.3.4 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mister dot v at laposte dot net
New email:
PHP Version: OS:

 

 [2004-06-07 11:59 UTC] mister dot v at laposte dot net
Description:
------------
I created a script using ob_start('callback'), and i think the probleme is link to the use of this function. (no problems when not using it)

when executing this script on local machine with PHP 4.3 their is no problems, but when I execute the same script online on a server with PHP 4.1, I sometimes get this error :

Fatal error: Maximum execution time of 30 seconds exceeded in Unknown on line 0

This error doesn't appear all the time. I couldn't find a reason why it happens. If i'm on a page and got no problems, I reload it and it can appear, or not.

All the script is executed.
I get all the page, without problems, but the navigator is still waiting for something and after quite a long time (probably 30s : max execution time) the error message appears.

( excuse me for my poor english )

Reproduce code:
---------------
don't know where the problem come from, so i can't show any code.

The error appears on this web site :
http://www.ingetech.fr

Actual result:
--------------
all the script is executed but I get a strange Max execution time :

Fatal error: Maximum execution time of 30 seconds exceeded in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-07 18:23 UTC] mister dot v at laposte dot net
The problem was coming from a function I declared. It was too long to execute on an old php version.

this fonction was a replacement for the missing html_entities_decode(). (doesn't exist on php 4.1)

I still don't know why the error was like this (in Unknown on
line 0) but this problem doesn't appear in earlier versions so forget it.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 17 10:03:37 2021 UTC