php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28640 problem with umlaut in wddx_deserialize
Submitted: 2004-06-05 10:50 UTC Modified: 2004-12-07 08:35 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: clemens at gutweiler dot net Assigned:
Status: Not a bug Package: WDDX related
PHP Version: 5.0.0RC2 OS: Linux 2.6.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: clemens at gutweiler dot net
New email:
PHP Version: OS:

 

 [2004-06-05 10:50 UTC] clemens at gutweiler dot net
Description:
------------
wddx_deserialize stops deserializing at german umlaut character.

PHP Version: 5.0.0RC3RC2
This code works properly on PHP 4

Reproduce code:
---------------
<?php
	
	$wddx_data = 'test';
	var_dump( wddx_deserialize( wddx_serialize_value( $wddx_data ) ) );
	
	$wddx_data = 'te?st';
	var_dump( wddx_serialize_value( $wddx_data ) );
	var_dump( wddx_deserialize( wddx_serialize_value( $wddx_data ) ) );
	
	$wddx_data = array( 'string' => 'te?st' );
	var_dump( wddx_deserialize( wddx_serialize_value( $wddx_data ) ) );
	
?>

Expected result:
----------------
string(4) "test"
string(83) "<wddxPacket version='1.0'><header/><data><string>te?st</string></data></wddxPacket>"
string(5) "te?st"
array(1) {
  ["string"]=>
  string(5) "te?st"
}


Actual result:
--------------
string(4) "test"
string(83) "<wddxPacket version='1.0'><header/><data><string>te?st</string></data></wddxPacket>"
string(2) "te"
NULL


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-18 14:36 UTC] clemens at gutweiler dot net
<?php
	var_dump( wddx_deserialize( '<?xml version="1.0" encoding="ISO-8859-1" ?>'."\n".wddx_serialize_value( 'te?st' ) ) );
?>

this works.
it works also if the data are encoded with utf-8.

but is a bc break!
 [2004-12-07 08:35 UTC] tony2001@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You have to convert your data to UTF8 if it contains non-ASCII characters. The documentation was wrong about setlocale() and this is alrady fixed.  
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 13:01:23 2020 UTC