php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28572 termination because of max_input_time returns error for max_execution_time
Submitted: 2004-05-30 00:38 UTC Modified: 2004-05-31 00:03 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: rohezal2000 at yahoo dot de Assigned:
Status: Wont fix Package: PHP options/info functions
PHP Version: 4.3.5 OS: Windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
39 - 13 = ?
Subscribe to this entry?

 
 [2004-05-30 00:38 UTC] rohezal2000 at yahoo dot de
Description:
------------
(I am posting the following as a documentation problem, since it refers to an unclear error message returned by PHP. It has nothing to do with the online documentation or any help files.)

If a script is terminated because the uploading process (e.g. the sending of POST data) takes too long, an error message is returned stating that the script was terminated because of exceeding the max_execution_time.

I was using a script to save files uploaded with POST to the server's harddisk. If it was a larger file, the following error message was returned:

Fatal error: Maximum execution time of 30 seconds exceeded in e:\www\apache\htdocs\ul\index.php on line 7

Since the script itself only needs seconds to execute, this led me to the false conclusion, that the uploading time is counted as script execution time. However, the error could not be corrected by setting the max_execution_time to a high value.
The error message for termination because of script running time should not be used for termination because of input time to avoid confusion.

(I am sorry if I double post this bug, the AND wordsearch in the bug area does not seem to work for me - I already filed a bug report about this)

Reproduce code:
---------------
php.ini:
max_execution_time = 14400     ; Maximum execution time of each script, in seconds
max_input_time = 60	; Maximum amount of time each script may spend parsing request data

line 7 of my script:
<?php

POST data to a script which takes over 60 seconds to send to get the error message.

Expected result:
----------------
A message stating that the problem is the max_input_time variable, e.g.:

Fatal error: Maximum input time of 60 seconds exceeded in e:\www\apache\htdocs\ul\index.php on line 7

Actual result:
--------------
Fatal error: Maximum execution time of 14400 seconds exceeded in e:\www\apache\htdocs\ul\index.php on line 7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-30 10:55 UTC] nlopess@php.net
I've documented this a little bit in the feature section.

However, if PHP is displaying a wrong message, it isn't a documentation problem.
 [2004-05-30 19:59 UTC] iliaa@php.net
The error message cannot be changed because the time taken 
to process the input is being measures by the very same 
mechanism as that timing the script execution. 
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 10:01:25 2019 UTC