php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2847 imap_search - dates don't work
Submitted: 1999-11-27 22:52 UTC Modified: 2002-06-16 09:01 UTC
From: burton at gozoom dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 3.0.12 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: burton at gozoom dot com
New email:
PHP Version: OS:

 

 [1999-11-27 22:52 UTC] burton at gozoom dot com
when I call the imap_search function with 
criteria which includes dates, the search
seems to fail.

This will work:
subject "image"

This will fail:
subject "image" since 1-Jan-1997


I'm using the Cyrus IMAP server.  Both strings 
work fine if I submit them directly to the 
IMAP server by telnetting in.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-03-15 10:20 UTC] hholzgra at cvs dot php dot net
at least some of the search_related functions 
in c-client seem to be stuck with IMAPv2
causing this (and maybe other) problems ?
 [2000-03-15 13:37 UTC] burton at gozoom dot com
after looking at the c-client library and PHP's implementation in
imap.c, I think the problem is the use of the mail_criteria() 
function.
It is restricted to IMAP2.

It should be possible to get full IMAP search functionality
by creating and filling in the SEARCHPGM *pgm argument to
mail_search_full() directly. 
 [2002-06-16 09:01 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 11:03:37 2021 UTC