php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28366 apxs:Error: Command failed with rc=65536
Submitted: 2004-05-12 10:55 UTC Modified: 2004-05-17 15:33 UTC
From: rehanann at kfupm dot edu dot sa Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.6 OS: Aix 5.2 ML 2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rehanann at kfupm dot edu dot sa
New email:
PHP Version: OS:

 

 [2004-05-12 10:55 UTC] rehanann at kfupm dot edu dot sa
Description:
------------
While installing the PHP with Apache, mysql, imap and xml i got this error in make install.

the compilition options are.
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-ftp --with-pear --with-mysql=/usr/local/mysql --enable-shared --with-trans-sid --enable-mod_charset --enable-mysql --enable-ftp --with-imap-ssl=/usr/local/ssl --with-ssl --enable-ssl 


Reproduce code:
---------------
Installing PHP SAPI module:       apache2handler
/usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la /usr/local/apache2/modules
rm -f /usr/local/apache2/modules/libphp4.so
/usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish /tmp/horde/php/libs'
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: /usr/local/apache2/modules/libphp4.so: A file or directory in the path name does not exist.
apxs:Error: Command failed with rc=65536
.
make: 1254-004 The error code from the last command is 1.


Expected result:
----------------
Php should compiled with apache.

Actual result:
--------------
apxs:Error: Command failed with rc=65536


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-12 15:32 UTC] iliaa@php.net
Please do ls -l .libs  
 [2004-05-15 07:21 UTC] rehanann at kfupm dot edu dot sa
This is the list for .libs directory as requested.

# ls -l .libs
total 25816
-rw-r--r--   1 root     system      6647697 May 12 08:26 libphp4.a
-rw-r--r--   1 root     system        33854 May 12 08:26 libphp4.exp
lrwxrwxrwx   1 root     system           13 May 12 08:26 libphp4.la -> ../libphp4.la
-rw-r--r--   1 root     system          763 May 12 08:26 libphp4.lai
-rwxr-xr-x   1 root     system      6527021 May 12 08:26 libphp4.so
 [2004-05-16 09:19 UTC] rehanann at kfupm dot edu dot sa
Still I am waiting the reply.
 [2004-05-16 16:24 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

The problem appears to be with the Apache's apxs tool that 
fails to copy libphp4.so into the appropriate directory. 
 [2004-05-17 07:00 UTC] rehanann at kfupm dot edu dot sa
If this is not the problem with PHP so why PHP easily compile with other software not only with Apache.

Waiting for reply with correct solution.
 [2004-05-17 15:33 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Because in other instances apxs tool is not needed. 
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 23:01:32 2024 UTC