php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28270 any call to error_log(...) crashes - revisited
Submitted: 2004-05-04 07:30 UTC Modified: 2004-05-11 19:27 UTC
From: leha2 at mail dot ru Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.3.6 OS: Win32 (in my case WinXPPro+SP1)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: leha2 at mail dot ru
New email:
PHP Version: OS:

 

 [2004-05-04 07:30 UTC] leha2 at mail dot ru
Description:
------------
This report is just a reminder about "Bug #16787  	any call to error_log(...) crashes", that was posted to bugtrace two years ago.
I've added a comment there with description of troubles I've encounter after migrating from PHP v.4.1.0 to 4.3.5, and then to 4.3.6.
Quick URL for viewing that post is: http://bugs.php.net/bug.php?id=16787

Thanks for help in advance,
LeXa2

Reproduce code:
---------------
Here is a fragment of modified FastTemplate class, where the trouble was first encountered:
        function show_unknowns ($Line)
        {
                $unknown = array();
                if (ereg("({[A-Z0-9_]+})",$Line,$unknown))
                {
                        $UnkVar = $unknown[0];
                        if(!(empty($UnkVar)))
                        {
this is the trouble line =====>                               @error_log("[FastTemplate] Warning: no value found for variable: $UnkVar ",0);
                        }
                }
        }        // end show_unknowns()


Expected result:
----------------
just to log error as usual

Actual result:
--------------
PHP stalls and I have to kill it's process via Task Manager. After that I got 500 Internal Server Error (not surprising, really ;)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-04 09:03 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Reopen the old report, NEVER refile an existing bug please.
 [2004-05-11 19:27 UTC] leha2 at mail dot ru
The trouble is that I need a password to change the status of that bug to Open, so I simply can't reopen it. Another strange thing is that my comment to that bug (#16787) has been deleted somehow, so, looks like this report is the only place for this  bug to be described ;). In any case, I can deal without error_log() in PHP, while it's your work to improve PHP and fix bugs. So, if you don't need my report - just delete it or ignore. That's it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Sep 27 01:01:24 2020 UTC