php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28206 zlib.output_compression=on do garbage output
Submitted: 2004-04-28 17:13 UTC Modified: 2004-04-29 23:48 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: daniel at chatologica dot com Assigned:
Status: Closed Package: Zlib related
PHP Version: 4.3.6 OS: RedHat7.1 & 9
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: daniel at chatologica dot com
New email:
PHP Version: OS:

 

 [2004-04-28 17:13 UTC] daniel at chatologica dot com
Description:
------------
If I set in php.ini 
zlib.output_compression = On 
the php scripts will produce garbage output in the browser.

The same php.ini configuration but with php v4.3.4 work good.

Zlib 1.1.4 enabled



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-29 15:28 UTC] iliaa@php.net
What webserver are you using (and modules are running in 
it)? Also, are you using any other PHP buffers, sessions, 
etc.. ? 
 [2004-04-29 22:51 UTC] daniel at chatologica dot com
Also it will not work on RedHat9
Here are the phpinfo for RedHat9:
http://chatologica.com/phpinfo.php.html
only have to put the option zlib.output_compression on to get the exact configuration.

Also here is the phpinfo for RefHat7.1:
http://chatologica.com/FMSE/phpinfo.php - here just replace 4.3.4 with 4.3.6 and you will get the exact configuration.

I had to install 4.3.4 because 4.3.6 with the same php.ini produced garbage outputs.
 [2004-04-29 23:48 UTC] daniel at chatologica dot com
Yes this fixed the problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 16:01:24 2020 UTC