php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28197 msg_receive doesn't block
Submitted: 2004-04-28 02:11 UTC Modified: 2004-04-28 17:17 UTC
From: neo at gothic-chat dot de Assigned:
Status: Not a bug Package: Semaphore related
PHP Version: 4.3.4 OS: FreeBSD 5.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: neo at gothic-chat dot de
New email:
PHP Version: OS:

 

 [2004-04-28 02:11 UTC] neo at gothic-chat dot de
Description:
------------
On my developement-system (FreeBSD 5.1), msg_receive doesn't block until a new message arrives, even if MSG_IPC_NOWAIT is not passed to flags. msg_receive will return immediately, returning false.

Reproduce code:
---------------
while (true) {
   $rcv = msg_receive ($key, 0, $msg_type, 65536, $msginfo, true, 0);
   var_dump ($rcv));
}

Expected result:
----------------
The script should block until msg_receive returns true


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-28 09:32 UTC] wez@php.net
And does it emit a warning or error message?
 [2004-04-28 14:46 UTC] neo at gothic-chat dot de
Kernel errno was 13 -> 62 #define EACCES 13 /* Permission denied */
Doubleckecked permissions, now working.
Sorry.
 [2004-04-28 17:17 UTC] wez@php.net
Not a bug then :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC