php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28172 Crazy error when commenting out a simplexml var
Submitted: 2004-04-27 01:02 UTC Modified: 2004-05-05 01:06 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: scholzrobert at web dot de Assigned:
Status: Closed Package: SimpleXML related
PHP Version: 5.0.0RC2 OS: Fedora C1 (Linux 2.6.5)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: scholzrobert at web dot de
New email:
PHP Version: OS:

 

 [2004-04-27 01:02 UTC] scholzrobert at web dot de
Description:
------------
I have the Object $xml. It has the simplexml Obj $xml::xml. The "reproduce code" lines stop my apache2 for this one script. Firefox does not load the page, konqueror says that "Connction to localhost ist broken" and IE displas a site which says "technical problems".

Reproduce code:
---------------
// $xml->xml->news->text
/* $xml->xml->news->text */
# $xml->xml->news->text

Expected result:
----------------
Nothing, it's only a comment to remember how ot worked before

Actual result:
--------------
Firefox does not load the page, konqueror says connection broken and IE displays a "technical error" page.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-27 08:25 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try avoid embedding huge scripts into the report.
 [2004-05-05 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2004-05-05 01:06 UTC] scholzrobert at web dot de
Can't reproduce this bug (apache 2.0.48/49).
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 26 12:01:29 2024 UTC