php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28132 php_pdf.dll version error
Submitted: 2004-04-23 23:58 UTC Modified: 2004-04-24 00:04 UTC
From: dpfender at nctv dot com Assigned:
Status: Not a bug Package: *PDF functions
PHP Version: 4.3.6 OS: Windows 2000 SP4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dpfender at nctv dot com
New email:
PHP Version: OS:

 

 [2004-04-23 23:58 UTC] dpfender at nctv dot com
Description:
------------
I just installed version 4.3.6, including several php_xxx.dll files.  In php.ini, I configured php_pdf.dll, as I had in previous versions.  I then executed php -v on the command line and got the following error:
PHP Fatal error:  PDFlib error: Version mismatch in wrapper code in Unknown on line 0

If I remove the dll from the php.ini configuration, the error disappears.  I double-checked that I had loaded the newest dll files in the system32 directory.  The version 4.3.5 dll was 528KB and the version 4.3.6 dll is 72KB. Something does not seem proper.  If I re-install the version 4.3.5 php_pdf.dll, there are no errors.

Reproduce code:
---------------
php -v

Expected result:
----------------
no errors

Actual result:
--------------
D:\WINNT>php -v
PHP Fatal error:  PDFlib error: Version mismatch in wrapper code in Unknown on line 0
PHP 4.3.6 (cgi-fcgi) (built: Apr 14 2004 17:21:37)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-24 00:04 UTC] amt@php.net
Thanks for report, but this is a duplicate of Bug 28017.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 10:03:35 2021 UTC