php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28062 gettext produces ? instead of german special chars
Submitted: 2004-04-19 17:05 UTC Modified: 2004-04-22 00:51 UTC
From: soletan at toxa dot de Assigned:
Status: Not a bug Package: Gettext related
PHP Version: 4.3.6 OS: SuSE Linux 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: soletan at toxa dot de
New email:
PHP Version: OS:

 

 [2004-04-19 17:05 UTC] soletan at toxa dot de
Description:
------------
Hi,

I've upgraded from 4.3.5 to 4.3.6 immediately to keep as bug-free as possible. Now I detected some trouble using gettext. I use it to translate hardcoded english strings in script to be translated into german versions.

The latter ones contain special characters which are part of ISO-8859-1. These have been displayed properly under 4.3.5. Now I get questions marks instead. It must be a problem up to PHP, since I can switch back to the previously installed 4.3.5 to get working again. Both versions are compiled using identical config.nice-scripts.

I grepped the Changelog and didn't found any notice on gettext. So what's up with that?? I won't use that "safe" (bug-fixed) version 4.3.6, since many of the sites I'm hosting rely on gettext translation.


Thanks for your help in advance,
best regards.

Thomas Urban


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-19 17:08 UTC] soletan at toxa dot de
BTW: here's my config.nice:

#! /bin/sh
#
# Created by configure

'./configure' \
'--with-apxs2=/usr/local/httpd/bin/apxs' \
'--enable-discard-path' \
'--with-debug' \
'--enable-safe-mode' \
'--with-exec-dir' \
'--with-openssl' \
'--enable-sigchild' \
'--enable-maqic-quotes' \
'--enable-libgcc' \
'--with-zlib' \
'--enable-bcmath' \
'--with-bz2' \
'--enable-calendar' \
'--with-db3=/usr/local/BerkeleyDB4.1' \
'--enable-dio' \
'--enable-ftp' \
'--with-gd' \
'--enable-gd-native-ttf' \
'--enable-dl' \
'--with-ttf' \
'--with-t1lib' \
'--with-jpeg-dir' \
'--with-png-dir' \
'--with-gettext' \
'--with-imap' \
'--with-imap-ssl' \
'--enable-mbstring' \
'--enable-mbregex' \
'--with-mcrypt' \
'--with-mysql=/usr/local/mysql' \
'--with-tiff-dir' \
'--enable-sockets' \
'--with-regex' \
'--enable-tokenizer' \
'--with-xmlrpc' \
'--with-ming=/usr' \
"$@"
 [2004-04-19 20:30 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try avoid embedding huge scripts into the report.
 [2004-04-19 22:04 UTC] soletan at toxa dot de
For the moment forget about that. I tested around with it a bit and everything's working fine right now. I come back, if it re-appears.
 [2004-04-19 22:36 UTC] amt@php.net
Okay. Reopen this if that happens.
 [2004-04-22 00:51 UTC] soletan at toxa dot de
Okay, this problem appeared to be some kind of abnormal. It wasn't in relation to PHP's upgrade. It took me hours to get into depths but now there's a stable solution to avoid this problem:

After booting a server conversion failed as described, since gconv/iconv at libgettext produced question-marks on any German special character. Restarting the Apache2 once solved this problem until the system's next reboot.

So I moved on and checked PHP's result of calling setlocale and that way found that category LC_MESSAGES isn't documented in PHP manual pages (anymore?). Well, in this it's optionally available, but editing all calls of setlocale to use LC_ALL instead permanently solved the problem.

Software is okay, documentation/category support is nearly okay, too.


Best Regards
Thomas Urban
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 02:01:25 2020 UTC