php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27987 mysqli prepared statements crash mysqld on second execution
Submitted: 2004-04-13 23:57 UTC Modified: 2004-04-15 04:50 UTC
From: laura at cs dot rmit dot edu dot au Assigned: edink (profile)
Status: Wont fix Package: MySQL related
PHP Version: 5CVS-2004-04-15 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
34 + 37 = ?
Subscribe to this entry?

 
 [2004-04-13 23:57 UTC] laura at cs dot rmit dot edu dot au
Description:
------------
When using a mysqli prepared statement, first execution works.  Second execution crashes the MySQL server.  This is using PHP5RC1 and MySQL 5.0.0 alpha max and the sample code given at
http://www.php.net/manual/en/function.mysqli-prepare.php
(Example 1, OO style)

I suspect the problem is caused by a bug in older versions of the MySQL library, as documented here:
http://bugs.mysql.com/bug.php?id=2099
and here:
http://bugs.mysql.com/bug.php?id=1663

This bug has been fixed in newer versions of the library from MySQL but I would guess the PHP5 version is based on an older (pre January) version of the library.

Reproduce code:
---------------
http://www.php.net/manual/en/function.mysqli-prepare.php

Expected result:
----------------
Output as specified in the manual

Actual result:
--------------
MySQL server crash.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-14 10:14 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2004-04-14 13:05 UTC] laura at cs dot rmit dot edu dot au
Installed snapshot, tested, still have same bug.
 [2004-04-14 22:25 UTC] sniper@php.net
Edin, can you see if you can update the used mysql libs? (for mysqli..)
 [2004-04-15 04:50 UTC] edink@php.net
Sorry we are not able to upgrade the libs since mysql ab does not provide them.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 02:01:29 2024 UTC